Concrete CMS 9.5.0 and below is vulnerable to CSRF on download() in the package install controller
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/install/download/<remoteId>. The download() method in concrete/controllers/single_page/dashboard/extend/install.php checks only the canInstallPackages() permission before fetching a remote marketplace package and writing it to the server's DIR_PACKAGES directory. Because the endpoint is a state-changing GET route with no token enforcement, an attacker who can cause an authenticated administrator to visit a crafted page can force an arbitrary marketplace package to be downloaded. In order to be vulnerable, the victim must be passing canInstallPackages() and the site must be connected to the Concrete marketplace. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks https://github.com/maru1009 for reporting.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | concrete5/concrete5 (Packagist) | before 9.5.1 | 9.5.1 | Patch available | GHSA-r42c-3rr2-jrfp |
- concrete5/concrete5 (Packagist) Vendor— Affected before 9.5.1 Fixed in 9.5.1 Patch available GHSA-r42c-3rr2-jrfp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | up to 9.5.0 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions up to 9.5.0 Vulnerable ·Concrete CMS
Remediation
- Fix · GHSA-r42c-3rr2-jrfp concrete5/concrete5 (Packagist) Fixed in 9.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-8140
- 2026-10-03 Alias added: GHSA-r42c-3rr2-jrfp
References
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-8140 · CVE Program
- CVE-2026-8140 · NVD
- FIRST EPSS
- GHSA-r42c-3rr2-jrfp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences