Full RCE using EasyTimeline Extension
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
A vulnerability in Wikimedia Foundation timeline. This vulnerability is associated with program files scripts/EasyTimeline.Pl, includes/Timeline.Php. This issue affects timeline: from * before 1.46.0, 1.45.4, 1.44.6, 1.43.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | timeline | before 1.46.0, 1.45.4, 1.44.6, 1.43.9 | 1.46.0, 1.45.4, 1.44.6, 1.43.9 | Patch available | CNA |
- timeline VendorWikimedia Foundation Affected before 1.46.0, 1.45.4, 1.44.6, 1.43.9 Fixed in 1.46.0, 1.45.4, 1.44.6, 1.43.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | 1.43.0 to before 1.43.9; 1.44.0 to before 1.44.6; 1.45.0 to before 1.45.4 | Vulnerable | mediawiki |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.43.0 to before 1.43.9; 1.44.0 to before 1.44.6; 1.45.0 to before 1.45.4 Vulnerable ·mediawiki
Remediation
- Fix · CNA timeline (Wikimedia Foundation) Fixed in 1.46.0, 1.45.4, 1.44.6, 1.43.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation timeline 1.46.0, 1.45.4, 1.44.6, 1.43.9
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-41793 Stored XSS through javascript URLs in SVGs generated by EasyTimelinePriority LOW 3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-8857
- 2026-10-03 Alias added: GHSA-q6xp-j96f-7vmp
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-8857 · CVE Program
- CVE-2026-8857 · NVD
- FIRST EPSS
- GHSA-q6xp-j96f-7vmp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences