Agile Store Locator < 1.6.9 - Admin+ Arbitrary File Read via Path Traversal
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
The Store Locator WordPress plugin before 1.6.9 does not validate a parameter before using it in a file path, allowing high-privileged users such as administrators to read arbitrary `.php` files from the server, including configuration files that contain database credentials and authentication keys.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Store Locator WordPress | before 1.6.9 | 1.6.9 | Patch available | CNA |
- Store Locator WordPress VendorUnknown Affected before 1.6.9 Fixed in 1.6.9 Patch available CNA
Remediation
- Fix · CNA Store Locator WordPress (Unknown) Fixed in 1.6.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Store Locator WordPress 1.6.9
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2026-07963 Agile Store Locator < 1.6.9 - Admin+ Stored XSS via logo_namePriority MEDIUM 50
Timeline
- 2026-10-02 Threatist record created from CVE-2026-9062
- 2026-10-03 Alias added: GHSA-553w-8mm7-5gf2
References
Sources
- CVE-2026-9062 · CVE Program
- CVE-2026-9062 · NVD
- FIRST EPSS
- GHSA-553w-8mm7-5gf2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences