Server-side request forgery in mautic/core
Priority LOW 27CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
A Server-Side Request Forgery (SSRF) vulnerability exists in Mautic's Focus component. Due to insufficient validation of user-supplied URLs, an authenticated user can trigger outbound HTTP requests from the hosting server, enabling internal network reconnaissance or forcing requests to arbitrary internal or external destinations.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00146 3rd percentileScored 2026-11-07
Fix Fixed mautic/core: 4.4.20, 5.2.11, 6.0.9 +1mautic/core (Packagist): 5.2.11, 6.0.9, 7.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | mautic/core | 4.0.0 to before 4.4.20; 5.0.0 to before 5.2.11; 6.0.0 to before 6.0.9; 7.0.0 to before 7.1.2 | 4.4.20, 5.2.11, 6.0.9, 7.1.2 | Patch available | CNA |
| — | mautic/core (Packagist) | 4.0.0 – 4.4.13 | — | No fix listed | GHSA-jmv8-8j9j-rcpc |
| — | mautic/core (Packagist) | 5.0.0 to before 5.2.11 | 5.2.11 | Patch available | GHSA-jmv8-8j9j-rcpc |
| — | mautic/core (Packagist) | 6.0.0 to before 6.0.9 | 6.0.9 | Patch available | GHSA-jmv8-8j9j-rcpc |
| — | mautic/core (Packagist) | 7.0.0 to before 7.1.2 | 7.1.2 | Patch available | GHSA-jmv8-8j9j-rcpc |
- mautic/core Vendor— Affected 4.0.0 to before 4.4.20; 5.0.0 to before 5.2.11; 6.0.0 to before 6.0.9; 7.0.0 to before 7.1.2 Fixed in 4.4.20, 5.2.11, 6.0.9, 7.1.2 Patch available CNA
- mautic/core (Packagist) Vendor— Affected 4.0.0 – 4.4.13 Fixed in — No fix listed GHSA-jmv8-8j9j-rcpc
- mautic/core (Packagist) Vendor— Affected 5.0.0 to before 5.2.11 Fixed in 5.2.11 Patch available GHSA-jmv8-8j9j-rcpc
- mautic/core (Packagist) Vendor— Affected 6.0.0 to before 6.0.9 Fixed in 6.0.9 Patch available GHSA-jmv8-8j9j-rcpc
- mautic/core (Packagist) Vendor— Affected 7.0.0 to before 7.1.2 Fixed in 7.1.2 Patch available GHSA-jmv8-8j9j-rcpc
Remediation
- Fix · CNA mautic/core Fixed in 4.4.20, 5.2.11, 6.0.9, 7.1.2
- Fix · GHSA-jmv8-8j9j-rcpc mautic/core (Packagist) Fixed in 5.2.11 Advisory →
- Fix · GHSA-jmv8-8j9j-rcpc mautic/core (Packagist) Fixed in 6.0.9 Advisory →
- Fix · GHSA-jmv8-8j9j-rcpc mautic/core (Packagist) Fixed in 7.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-9557
- 2026-10-03 Alias added: GHSA-jmv8-8j9j-rcpc
References
Sources
- CVE-2026-9557 · CVE Program
- CVE-2026-9557 · NVD
- FIRST EPSS
- GHSA-jmv8-8j9j-rcpc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences