CoCart < 4.9.0 - Unauthenticated Arbitrary Price Manipulation
Priority HIGH 72CWE-472Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The CoCart WordPress plugin before 4.9.0 does not validate a user-supplied price value against the actual product price when items are added to the cart through one of its public REST API endpoints, allowing unauthenticated users to set arbitrary product prices and complete WooCommerce orders at manipulated totals.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00382 32nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed CoCart (Unknown): 4.9.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | CoCart | before 4.9.0 | 4.9.0 | Patch available | CNA |
- CoCart VendorUnknown Affected before 4.9.0 Fixed in 4.9.0 Patch available CNA
Remediation
- Fix · CNA CoCart (Unknown) Fixed in 4.9.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-10524
- 2026-10-03 Alias added: GHSA-2xcr-jvj8-gv2p
References
Sources
- CVE-2026-10524 · CVE Program
- CVE-2026-10524 · NVD
- FIRST EPSS
- GHSA-2xcr-jvj8-gv2p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences