theonedev REST API default-branch improper authorization
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-266 and CWE-285.
Summary
A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| theonedev | onedev | 15.0.0; 15.0.1; 15.0.2; 15.0.3; 15.0.4; 15.0.5 | 15.0.6 | Patch available | CNA |
- onedev Vendortheonedev Affected 15.0.0; 15.0.1; 15.0.2; 15.0.3; 15.0.4; 15.0.5 Fixed in 15.0.6 Patch available CNA
CPE names CNA · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:theonedev:onedev:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:theonedev:onedev:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
- Fix · CNA onedev (theonedev) Fixed in 15.0.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-11440
- 2026-10-03 Alias added: GHSA-2g53-8j24-x4mg
References
More theonedev vulnerabilities
- TI-2021-04345 Pre-Auth Unsafe Deserialization on AttachmentUploadServet CVSS 3.1CRITICAL 10.0
- TI-2022-18585 CI/CD Docker Escape in OneDev CVSS 3.1CRITICAL 9.9
- TI-2022-18584 Access Control Bypass in Onedev CVSS 3.1CRITICAL 9.8
- TI-2021-04346 Pre-Auth Unsafe Deserialization on KubernetesResource CVSS 3.1CRITICAL 10.0
- TI-2022-18587 Git Repository Disclosure in Onedev CVSS 3.1HIGH 7.5
- TI-2021-04349 Pre-Auth Access token leak CVSS 3.1HIGH 8.6
Sources
- CVE-2026-11440 · CVE Program
- CVE-2026-11440 · NVD
- FIRST EPSS
- GHSA-2g53-8j24-x4mg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences