Read the docs
TI-2026-10020 Aliases CVE-2026-11605GHSA-qhh7-j7w3-xfxq

Unnecessary validation of DNSSEC signed records

Priority MEDIUM 40CWE-408Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 1 fixed, 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.

Summary

The issue is a resource exhaustion vulnerability associated with DNSSEC validation. BIND always validates all RRSIG records in an answer, even if they are not strictly needed. A query to an authoritative server/zone which returns many valid but superfluous RRSIG records causes the validator to waste disproportionate CPU time. This issue affects BIND 9 versions 9.20.0 through 9.20.24, 9.21.0 through 9.21.23, and 9.20.9-S1 through 9.20.24-S1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00672 52nd percentileScored 2026-11-07
Fix Partial Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.20.0 – 9.20.24; 9.21.0 – 9.21.23; 9.20.9-S1 – 9.20.24-S1—No fix listedCNA
  • BIND 9 VendorISC Affected 9.20.0 – 9.20.24; 9.21.0 – 9.21.23; 9.20.9-S1 – 9.20.24-S1 Fixed in — No fix listed CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.20.0 – 9.20.24VulnerableISC
cpe:2.3:a:isc:bind:*:*:*:*:supported_preview:*:*:*9.20.9 – 9.20.24VulnerableISC
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.21.0 – 9.21.23VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.20.0 – 9.20.24 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:*:*:*:*:supported_preview:*:*:* Versions 9.20.9 – 9.20.24 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.21.0 – 9.21.23 Vulnerable ·ISC

Remediation

Red Hat 1 advisory

  • RHSA-2026:42853 Released 2026-07-21 · Red Hat rating Important
    Red Hat Hardened Images RPMs bug fix and enhancement update
    • Red Hat Hardened Images bind-32:9.18.50-22.hum1@aarch64, bind-32:9.18.50-22.hum1@src, bind-32:9.18.50-22.hum1@x86_64 +12

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 9Affected—
Red Hat OpenShift Container Platform 5AffectedNo fix yet
Red Hat Hardened ImagesFixed RHSA-2026:42853
Not affected: 6 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-11605
  2. 2026-10-03 Alias added: GHSA-qhh7-j7w3-xfxq
  3. 2026-10-25 EPSS moved to the 50th–90th percentile
  4. 2026-10-30 Affected versions changed · Red Hat

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources