Fluent Forms < 6.2.6 - Contributor+ Stored XSS via Date/Time Field
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Fluent Forms WordPress plugin before 6.2.6 does not sanitise and escape one of its form field configuration settings before outputting it inside an inline script when a form is rendered, which could allow users with a role as low as Contributor (with delegated form-management permission, and therefore lacking the unfiltered_html capability, e.g. in a multisite setup) to perform Stored Cross-Site Scripting attacks that execute in the browser of any visitor who loads the form, including administrators previewing it.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Fluent Forms | before 6.2.6 | 6.2.6 | Patch available | CNA |
- Fluent Forms VendorUnknown Affected before 6.2.6 Fixed in 6.2.6 Patch available CNA
Remediation
- Fix · CNA Fluent Forms (Unknown) Fixed in 6.2.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-11881
- 2026-10-03 Alias added: GHSA-x2rq-2q3v-fw75
References
Sources
- CVE-2026-11881 · CVE Program
- CVE-2026-11881 · NVD
- FIRST EPSS
- GHSA-x2rq-2q3v-fw75 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences