Incorrect permissions in ArubaSign by Aruba
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Incorrect default permissions in ArubaSign, affecting versions prior to v4.6.6. The vulnerability is caused by the assignment of inappropriate permissions during the software’s default installation, whereby the main executable and other programme files located in C:\Program Files have excessive permissions for the ‘Everyone’ group. This could allow an unprivileged user to replace the main executable and/or its components with a malicious file, thereby enabling the execution of arbitrary code. In the worst-case scenario, if the malicious code is executed with elevated privileges (such as those of Administrator or SYSTEM), the attacker could escalate privileges and gain full control of the system, compromising both security and data integrity.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ArubaSign (Aruba) Fixed in 4.6.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12602
- 2026-10-03 Alias added: GHSA-58j4-vm73-hgvh
References
More Aruba vulnerabilities
- TI-2007-00907 Heap-based buffer overflow in the management interfaces in (1) Aruba Mobility Controllers… CVSS 2.0HIGH 7.5
- TI-2007-00908 The (1) Aruba Mobility Controllers 200, 600, 2400, and 6000 and (2) Alcatel-Lucent… CVSS 2.0HIGH 7.5
- TI-2023-24045 WordPress Aruba HiSpeed Cache Plugin <= 2.0.6 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2021-13632 A remote denial of service (DoS) vulnerability was discovered in some Aruba Instant… CVSS 3.1MEDIUM 6.5
- TI-2021-13631 Cross-site scripting in Aruba Instant Access Points CVSS 3.1MEDIUM 6.1
- TI-2007-03894 Cross-site scripting (XSS) vulnerability in the login CGI program in Aruba Mobility… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2026-12602 · CVE Program
- CVE-2026-12602 · NVD
- FIRST EPSS
- GHSA-58j4-vm73-hgvh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences