Read the docs
TI-2026-10811 Aliases CVE-2026-12617GHSA-cc7q-gqfw-hrm4

Record ordering based unexpected exit with CNAME or DNAME

Priority LOW 39CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-617.

Summary

The issue is unexpected program termination based on ordering and/or specific content in responses to queries for CNAME or DNAME, and A records. Specifically, if a client queries for a DNAME and A record below the DNAME to the resolver, and the authoritative server responds positively to the A query but delays the DNAME response and later responds negatively, `named` may quit unexpectedly. Or, if a client queries for a CNAME and A record for the same name to the resolver, and the authoritative server responds positively to the A query but delays the CNAME response and later responds with a self-referential CNAME, the same failure may occur. This issue affects BIND 9 versions 9.18.0 through 9.18.50, 9.20.0 through 9.20.24, 9.18.11-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.24-S1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00524 44th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.18.0 – 9.18.50; 9.20.0 – 9.20.24; 9.18.11-S1 – 9.18.50-S1; 9.20.9-S1 – 9.20.24-S1—No fix listedCNA
  • BIND 9 VendorISC Affected 9.18.0 – 9.18.50; 9.20.0 – 9.20.24; 9.18.11-S1 – 9.18.50-S1; 9.20.9-S1 – 9.20.24-S1 Fixed in — No fix listed CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.18.0 – 9.18.50VulnerableISC
cpe:2.3:a:isc:bind:*:*:*:*:supported_preview:*:*:*9.18.11 – 9.18.50VulnerableISC
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.20.0 – 9.20.24VulnerableISC
cpe:2.3:a:isc:bind:*:*:*:*:supported_preview:*:*:*9.20.9 – 9.20.24VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.18.0 – 9.18.50 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:*:*:*:*:supported_preview:*:*:* Versions 9.18.11 – 9.18.50 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.20.0 – 9.20.24 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:*:*:*:*:supported_preview:*:*:* Versions 9.20.9 – 9.20.24 Vulnerable ·ISC

Remediation

Red Hat 1 advisory

  • RHSA-2026:54071 Released 2026-08-12 · Red Hat rating Important
    Red Hat Hardened Images RPMs Security Update
    • Red Hat Hardened Images bind-32:9.20.26-0.1.hum1@aarch64, bind-32:9.20.26-0.1.hum1@src, bind-32:9.20.26-0.1.hum1@x86_64 +12

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Hardened ImagesFixed RHSA-2026:54071
Not affected: 7 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat OpenShift Container Platform 4
  • Red Hat OpenShift Container Platform 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-12617
  2. 2026-10-03 Alias added: GHSA-cc7q-gqfw-hrm4
  3. 2026-11-05 Affected versions changed · Red Hat

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources