Improper privilege management in Octopus Deploy Codefresh
Priority MEDIUM 40CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
In affected versions of the Codefresh platform an authenticated user can utilize an API endpoint to elevate to Admin permissions.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00423 36th percentileScored 2026-11-07
Fix Fixed Codefresh (Octopus Deploy): 2.11.15
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Codefresh | 2.0.0 to before 2.11.15 | 2.11.15 | Patch available | CNA |
- Codefresh VendorOctopus Deploy Affected 2.0.0 to before 2.11.15 Fixed in 2.11.15 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:codefresh:*:*:*:*:*:*:*:* | 2.0.0 to before 2.11.15 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:octopus:codefresh:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.11.15 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Codefresh (Octopus Deploy) Fixed in 2.11.15
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12878
- 2026-10-03 Alias added: GHSA-5g9x-76r7-xgp8
- 2026-10-25 Priority changed: LOW → MEDIUM
References
Sources
- CVE-2026-12878 · CVE Program
- CVE-2026-12878 · NVD
- FIRST EPSS
- GHSA-5g9x-76r7-xgp8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences