LearnPress < 4.4.4 - Instructor+ Server-Side Request Forgery via openai_apply_image_feature
Priority LOW 11CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.
Summary
The LearnPress WordPress plugin before 4.4.4 does not validate a user-supplied URL before the server fetches it, allowing users with the instructor role to induce the server to issue requests to arbitrary external hosts, a blind and bounded server-side request forgery.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00244 15th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed LearnPress (Unknown): 4.4.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LearnPress | before 4.4.4 | 4.4.4 | Patch available | CNA |
- LearnPress VendorUnknown Affected before 4.4.4 Fixed in 4.4.4 Patch available CNA
Remediation
- Fix · CNA LearnPress (Unknown) Fixed in 4.4.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12971
- 2026-10-03 Alias added: GHSA-w229-45jg-vp35
References
Sources
- CVE-2026-12971 · CVE Program
- CVE-2026-12971 · NVD
- FIRST EPSS
- GHSA-w229-45jg-vp35 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences