LearnPress < 4.4.4 - Subscriber+ Sensitive Information Exposure via AI Assistant
Priority MEDIUM 62CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-200.
Summary
The LearnPress WordPress plugin before 4.4.4 does not verify that a user is enrolled in a course before processing AI-assistant requests against that course's lesson content, allowing any authenticated user such as a subscriber to obtain material from paid courses they have not enrolled in.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00371 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed LearnPress (Unknown): 4.4.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LearnPress | before 4.4.4 | 4.4.4 | Patch available | CNA |
- LearnPress VendorUnknown Affected before 4.4.4 Fixed in 4.4.4 Patch available CNA
Remediation
- Fix · CNA LearnPress (Unknown) Fixed in 4.4.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12976
- 2026-10-03 Alias added: GHSA-3cx5-39h2-fchh
References
Sources
- CVE-2026-12976 · CVE Program
- CVE-2026-12976 · NVD
- FIRST EPSS
- GHSA-3cx5-39h2-fchh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences