Dynamic Pricing With Discount Rules for WooCommerce < 5.0.0 - Reflected XSS via wdpAjax
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Dynamic Pricing With Discount Rules for WooCommerce WordPress plugin before 5.0.0 does not validate a nonce or user capabilities on one of its AJAX actions and reflects unsanitised user input in the response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting against a victim who is induced to send a crafted request.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Dynamic Pricing With Discount Rules for WooCommerce | before 5.0.0 | 5.0.0 | Patch available | CNA |
- Dynamic Pricing With Discount Rules for WooCommerce VendorUnknown Affected before 5.0.0 Fixed in 5.0.0 Patch available CNA
Remediation
- Fix · CNA Dynamic Pricing With Discount Rules for WooCommerce (Unknown) Fixed in 5.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-13725
- 2026-10-03 Alias added: GHSA-m4wv-xhrh-3qf6
References
Sources
- CVE-2026-13725 · CVE Program
- CVE-2026-13725 · NVD
- FIRST EPSS
- GHSA-m4wv-xhrh-3qf6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences