WOLF - WordPress Posts Bulk Editor and Manager < 1.1.0 - Stored XSS via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352 and CWE-79.
Summary
The WOLF WordPress plugin before 1.1.0 does not perform a nonce or capability check on one of its AJAX actions, allowing an unauthenticated attacker to trick a logged-in administrator into writing arbitrary content, including a malicious script, into a post via a cross-site request, resulting in stored Cross-Site Scripting.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WOLF | before 1.1.0 | 1.1.0 | Patch available | CNA |
- WOLF VendorUnknown Affected before 1.1.0 Fixed in 1.1.0 Patch available CNA
Remediation
- Fix · CNA WOLF (Unknown) Fixed in 1.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-14234
- 2026-10-03 Alias added: GHSA-r4j4-29v7-6qph
References
Sources
- CVE-2026-14234 · CVE Program
- CVE-2026-14234 · NVD
- FIRST EPSS
- GHSA-r4j4-29v7-6qph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences