Read the docs
TI-2026-12137 Aliases CVE-2026-14355

ext/openssl: Memory corruption in openssl_encrypt with AES-WRAP-PAD

Priority LOW 25CWE-122Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.

Summary

In PHP versions 8.2.* before 8.2.32, 8.3.* before 8.3.32, 8.4.* before 8.4.23, 8.5.* before 8.5.8, the AES-WRAP-PAD algorithm implementation in OpenSSL extension contains a buffer allocation flaw. The output buffer for the AES key-wrap-with-padding operation is sized from the plaintext length without accounting for RFC 5649 expansion. This may cause OpenSSL to write beyond allocated memory, corrupting heap metadata and triggering application abort.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00279 20th percentileScored 2026-11-07
Fix Fixed php (php): 8.2.32, 8.3.32, 8.4.23 +1Red Hat: 8 advisories

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHPphp8.2.0 to before 8.2.32; 8.3.0 to before 8.3.32; 8.4.0 to before 8.4.23; 8.5.0 to before 8.5.88.2.32, 8.3.32, 8.4.23, 8.5.8Patch availableCNA
  • php VendorPHP Affected 8.2.0 to before 8.2.32; 8.3.0 to before 8.3.32; 8.4.0 to before 8.4.23; 8.5.0 to before 8.5.8 Fixed in 8.2.32, 8.3.32, 8.4.23, 8.5.8 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*8.2.0 to before 8.2.32; 8.3.0 to before 8.3.32; 8.4.0 to before 8.4.23; 8.5.0 to before 8.5.8VulnerablePHP
cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:*12.0VulnerableDebian
  • cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 8.2.0 to before 8.2.32; 8.3.0 to before 8.3.32; 8.4.0 to before 8.4.23; 8.5.0 to before 8.5.8 Vulnerable ·PHP
  • cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian

Remediation

  • Fix · CNA php (php) Fixed in 8.2.32, 8.3.32, 8.4.23, 8.5.8

Red Hat 8 advisories

  • RHSA-2026:61259 Released 2026-08-31 · Red Hat rating Low
    php security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 9) php-8.0.30-8.el9_8, php-bcmath-8.0.30-8.el9_8, php-cli-8.0.30-8.el9_8 +22
  • RHSA-2026:49914 Released 2026-08-04 · Red Hat rating Low
    php8.4 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 10) php8.4-8.4.23-1.el10_2, php8.4-bcmath-8.4.23-1.el10_2, php8.4-cli-8.4.23-1.el10_2 +22
  • RHSA-2026:48197 Released 2026-07-31 · Red Hat rating Low
    php:8.3 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.23-1.module+el9.8.0+24343+756b4fcd.noarch::php:8.3, php-8.3.32-1.module+el9.8.0+24508+6fcf2e7a.aarch64::php:8.3, php-8.3.32-1.module+el9.8.0+24508+6fcf2e7a.ppc64le::php:8.3 +47
Show 5 more Red Hat advisories
  • RHSA-2026:47749 Released 2026-07-30 · Red Hat rating Low
    php:8.2 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.23-1.module+el8.10.0+20770+a5eca186.noarch::php:8.2, libzip-1.7.3-1.module+el8.10.0+20770+a5eca186.aarch64::php:8.2, libzip-1.7.3-1.module+el8.10.0+20770+a5eca186.ppc64le::php:8.2 +47
  • RHSA-2026:47750 Released 2026-07-30 · Red Hat rating Low
    php:7.4 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.10.0+22485+a3539972.noarch::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.aarch64::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.ppc64le::php:7.4 +47
  • RHSA-2026:48170 Released 2026-07-29 · Red Hat rating Low
    php security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 10) php-8.3.32-1.el10_2, php-bcmath-8.3.32-1.el10_2, php-cli-8.3.32-1.el10_2 +22
  • RHSA-2026:40416 Released 2026-07-16 · Red Hat rating Low
    php:8.2 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.23-1.module+el9.7.0+24111+199d2cc4.noarch::php:8.2, php-8.2.32-1.module+el9.8.0+24509+ccb2f649.aarch64::php:8.2, php-8.2.32-1.module+el9.8.0+24509+ccb2f649.ppc64le::php:8.2 +47
  • RHSA-2026:34164 Released 2026-07-01 · Red Hat rating Moderate
    Red Hat Hardened Images RPMs bug fix and enhancement update
    • Red Hat Hardened Images php-8.5.8-2.hum1@aarch64, php-8.5.8-2.hum1@src, php-8.5.8-2.hum1@x86_64 +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 10)Fixed RHSA-2026:48170, RHSA-2026:49914
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2026:47749, RHSA-2026:47750
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2026:40416, RHSA-2026:48197, RHSA-2026:61259
Red Hat Hardened ImagesFixed RHSA-2026:34164
Not affected: 3 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-14355

References

  • TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
  • TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
  • TI-2015-00205 Heap-based buffer overflow in the __nss_hostname_digits_dots function in glibc 2.2, and… CVSS 2.0HIGH 10.0
See all 739 →

Sources