Possible XSS in the SNS web administration panel
Priority LOW 20CWE-79Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
It’s possible to run a stored XSS in Stormshield’s web administration panel. To exploit this vulnerability, a SNS administrator with appropriate permissions must inject some malicious script in a group’s comments in the webservices administration interface.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00235 14th percentileScored 2026-11-07
Fix Fixed Stormshield Network Security (Stormshield): 4.8.17, 5.0.7, 5.1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Stormshield | Stormshield Network Security | 4.8.0 – 4.8.16; 5.0.0 – 5.0.6 | 4.8.17, 5.0.7, 5.1.0 | Patch available | CNA |
- Stormshield Network Security VendorStormshield Affected 4.8.0 – 4.8.16; 5.0.0 – 5.0.6 Fixed in 4.8.17, 5.0.7, 5.1.0 Patch available CNA
Remediation
- Fix · CNA Stormshield Network Security (Stormshield) Fixed in 4.8.17, 5.0.7, 5.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-14466
- 2026-10-03 Alias added: GHSA-w9vr-4cw4-q9wq
References
More Stormshield vulnerabilities
- TI-2022-17498 zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in… CVSS 3.1CRITICAL 9.8
- TI-2023-00271 X.400 address type confusion in X.509 GeneralName CVSS 3.1HIGH 7.4
- TI-2022-13924 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
- TI-2023-06741 Buffer overflow in Cisco Secure Web Appliance CVSS 3.1CRITICAL 9.8
- TI-2022-13925 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
- TI-2022-04067 Double free after calling PEM_read_bio_ex CVSS 3.1HIGH 7.5
Sources
- CVE-2026-14466 · CVE Program
- CVE-2026-14466 · NVD
- FIRST EPSS
- GHSA-w9vr-4cw4-q9wq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences