Wallet System for WooCommerce < 2.7.10 - Customer+ Checkout Price Manipulation via Unvalidated Wallet Amount
Priority LOW 29CWE-472Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Wallet System for WooCommerce WordPress plugin before 2.7.10 does not validate a user-supplied wallet amount against the customer's actual stored balance during checkout, allowing authenticated customers to arbitrarily reduce their own order total, including down to zero, and complete checkout without paying the merchant.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00336 27th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Wallet System for WooCommerce (Unknown): 2.7.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Wallet System for WooCommerce | before 2.7.10 | 2.7.10 | Patch available | CNA |
- Wallet System for WooCommerce VendorUnknown Affected before 2.7.10 Fixed in 2.7.10 Patch available CNA
Remediation
- Fix · CNA Wallet System for WooCommerce (Unknown) Fixed in 2.7.10
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15045
- 2026-10-03 Alias added: GHSA-gf9j-rpmq-8vq3
References
Sources
- CVE-2026-15045 · CVE Program
- CVE-2026-15045 · NVD
- FIRST EPSS
- GHSA-gf9j-rpmq-8vq3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences