YayPricing < 3.5.7 - Subscriber+ Pricing Configuration Modification and Coupon Code Disclosure
Priority HIGH 70CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-284.
Summary
The YayPricing WordPress plugin before 3.5.7 does not perform capability checks on several of its REST API routes, relying only on a shared nonce, allowing any authenticated user such as a subscriber to overwrite the store's pricing configuration and to disclose private coupon codes.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0035 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed YayPricing (Unknown): 3.5.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | YayPricing | before 3.5.7 | 3.5.7 | Patch available | CNA |
- YayPricing VendorUnknown Affected before 3.5.7 Fixed in 3.5.7 Patch available CNA
Remediation
- Fix · CNA YayPricing (Unknown) Fixed in 3.5.7
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15230
- 2026-10-03 Alias added: GHSA-rhmm-6m6v-j5v4
References
Sources
- CVE-2026-15230 · CVE Program
- CVE-2026-15230 · NVD
- FIRST EPSS
- GHSA-rhmm-6m6v-j5v4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences