Content Views < 4.5 - Subscriber+ SQL Injection via preview_request
Priority HIGH 70CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The Content Views WordPress plugin before 4.5 does not perform a capability check on one of its AJAX actions and does not properly sanitise attacker-supplied data before using it in a SQL query, allowing any authenticated user, including Subscribers, to perform SQL injection attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00386 32nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Content Views (Unknown): 4.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Content Views | before 4.5 | 4.5 | Patch available | CNA |
- Content Views VendorUnknown Affected before 4.5 Fixed in 4.5 Patch available CNA
Remediation
- Fix · CNA Content Views (Unknown) Fixed in 4.5
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15361
- 2026-10-03 Alias added: GHSA-gp8v-vc4r-wpf4
References
Sources
- CVE-2026-15361 · CVE Program
- CVE-2026-15361 · NVD
- FIRST EPSS
- GHSA-gp8v-vc4r-wpf4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences