SecureAge CatchPulse Driver saappctl.sys heap-based overflow
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.
Summary
A security vulnerability has been detected in SecureAge CatchPulse up to 10.9.3. The affected element is an unknown function in the library saappctl.sys of the component Driver. Such manipulation leads to heap-based buffer overflow. An attack has to be approached locally. The exploit has been disclosed publicly and may be used. Upgrading to version 10.10.0 is sufficient to fix this issue. You should upgrade the affected component. The vendor was contacted early about this disclosure.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA CatchPulse (SecureAge) Fixed in 10.10.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15506
- 2026-10-03 Alias added: GHSA-j5fg-5g4v-6437
References
More SecureAge vulnerabilities
- TI-2026-09888 SecureAge CatchPulse IOCTL saappctl.sys information disclosure CVSS 4.0MEDIUM 4.8
- TI-2026-40378 Improper access control vulnerability in CatchPulse CVSS 3.1HIGH 8.4
- TI-2026-40380 Denial-of-service vulnerability in CatchPulse CVSS 3.1MEDIUM 5.5
- TI-2026-40379 Improper access control check in CatchPulse's named pipe communication interface CVSS 3.1MEDIUM 5.2
Sources
- CVE-2026-15506 · CVE Program
- CVE-2026-15506 · NVD
- FIRST EPSS
- GHSA-j5fg-5g4v-6437 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences