Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Looker | before 25.6.103; before 25.12.65; before 25.18.68; before 26.0.66; before 26.2.47; before 26.4.36; before 26.6.28; before 26.8.7 | 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, 26.8.7 | Patch available | CNA | |
| Looker | before 25.6.103; before 25.12.65; before 25.18.68; before 26.0.66; before 26.2.47; before 26.4.36; before 26.6.28; before 26.8.7 | 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, 26.8.7 | Patch available | CNA |
- Looker VendorGoogle Affected before 25.6.103; before 25.12.65; before 25.18.68; before 26.0.66; before 26.2.47; before 26.4.36; before 26.6.28; before 26.8.7 Fixed in 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, 26.8.7 Patch available CNA
- Looker VendorGoogle Affected before 25.6.103; before 25.12.65; before 25.18.68; before 26.0.66; before 26.2.47; before 26.4.36; before 26.6.28; before 26.8.7 Fixed in 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, 26.8.7 Patch available CNA
Remediation
- Fix · CNA Looker (Google Cloud) Fixed in 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, 26.8.7
- Fix · CNA Looker (Google Cloud) Fixed in 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, 26.8.7
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15810
- 2026-10-03 Alias added: GHSA-rvfx-gr5v-9r95
References
More Google vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2026-15810 · CVE Program
- CVE-2026-15810 · NVD
- FIRST EPSS
- GHSA-rvfx-gr5v-9r95 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences