Potential denial-of-service vulnerability via nested geometry collections
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 9 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-674.
Summary
An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18. GeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects supplied as well-known text (WKT), well-known binary (WKB), or hex-encoded WKB, which triggers unbounded recursion and a segmentation fault in the underlying GEOS library. Spatial field lookups and the `django.contrib.gis.forms.GeometryField` form field are also affected. Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected. Django would like to thank Andrew MacPherson and kimchunbok_ for reporting this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 6.0 to before 6.0.9; 5.2 to before 5.2.18 | 6.0.9, 5.2.18 | Patch available | CNA |
| — | django (PyPI) | before 5.2.17 | 5.2.17 | Patch available | GHSA-q238-5cxm-5c9h |
| — | django (PyPI) | 6.0a1 to before 6.0.8 | 6.0.8 | Patch available | GHSA-q238-5cxm-5c9h |
| — | django (PyPI) | 6.1a1 to before 6.1.1 | 6.1.1 | Patch available | GHSA-q238-5cxm-5c9h |
- Django Vendordjangoproject Affected 6.0 to before 6.0.9; 5.2 to before 5.2.18 Fixed in 6.0.9, 5.2.18 Patch available CNA
- django (PyPI) Vendor— Affected before 5.2.17 Fixed in 5.2.17 Patch available GHSA-q238-5cxm-5c9h
- django (PyPI) Vendor— Affected 6.0a1 to before 6.0.8 Fixed in 6.0.8 Patch available GHSA-q238-5cxm-5c9h
- django (PyPI) Vendor— Affected 6.1a1 to before 6.1.1 Fixed in 6.1.1 Patch available GHSA-q238-5cxm-5c9h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | before 5.2.17; 6.0 to before 6.0.8 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions before 5.2.17; 6.0 to before 6.0.8 Vulnerable ·djangoproject
Remediation
- Fix · CNA Django (djangoproject) Fixed in 6.0.9, 5.2.18
- Fix · GHSA-q238-5cxm-5c9h django (PyPI) Fixed in 5.2.17 Advisory →
- Fix · GHSA-q238-5cxm-5c9h django (PyPI) Fixed in 6.0.8 Advisory →
- Fix · GHSA-q238-5cxm-5c9h django (PyPI) Fixed in 6.1.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
djangoproject Django — Django security releases issued: 6.0.8 and 5.2.17
4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-12883 Server-side file-write and request forgery via spatial lookupsPriority MEDIUM 42
- TI-2026-12909 Potential denial-of-service vulnerability in check_for_language()Priority LOW 31
- TI-2026-13336 Potential cross-site scripting via URLField values in the adminPriority LOW 23
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 2 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 16.2 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 17.1 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 18.0 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
| Red Hat Update Infrastructure 4 for Cloud Providers | Affected | No fix planned: Out of support scope |
| Red Hat Update Infrastructure 5 | Affected | No fix yet: Fix deferred |
| Self-service automation portal 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15830
- 2026-10-03 Alias added: GHSA-q238-5cxm-5c9h
- 2026-10-08 Fix available: [email protected], [email protected] · CNA
- 2026-10-08 4 new references · CNA
- 2026-10-12 5 new references · GHSA-q238-5cxm-5c9h
References
Patch 9
- Django security archive
- https://github.com/django/django/commit/d2e59b77fe18de318a8272c2a7bbc798d84d1d0d
- https://github.com/django/django/commit/9e4a3f186b6b07b483bfd9195ea06734663fcd06
- https://github.com/django/django/commit/6af5da31775417c610dbf9c3f1b5b8333d42daf6
- https://github.com/django/django/commit/ba80833fa656dd09660b97c4429331067db1b080
- https://github.com/django/django/commit/62ef9d40cf4ea75f16518436b44b8ab2515340df
- https://github.com/django/django/commit/75d401a1491e04a907ed745c128836d51c982c0f
- https://github.com/django/django/commit/4353dfb56f8ba3a6fccc4bdd7f2ef2fbee3aa638
- https://github.com/django/django/commit/1eafa1a80f1363283f89208ba4499ed54e35f085
Advisory 3
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-15830 · CVE Program
- CVE-2026-15830 · NVD
- FIRST EPSS
- GHSA-q238-5cxm-5c9h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-15830 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences