Post Grid, Slider & Carousel Ultimate < 1.8.1 - Contributor+ Stored XSS via Header Title Field
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Grid, Slider & Carousel Ultimate WordPress plugin before 1.8.1 does not sanitise and escape one of its custom post type settings before outputting it in an HTML attribute on the admin edit screen, allowing users with the Contributor role and above to inject JavaScript that executes in the session of any administrator who opens the affected item.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Post Grid, Slider & Carousel Ultimate | before 1.8.1 | 1.8.1 | Patch available | CNA |
- Post Grid, Slider & Carousel Ultimate VendorUnknown Affected before 1.8.1 Fixed in 1.8.1 Patch available CNA
Remediation
- Fix · CNA Post Grid, Slider & Carousel Ultimate (Unknown) Fixed in 1.8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-16260
- 2026-10-03 Alias added: GHSA-9jf6-vw36-77hj
References
Sources
- CVE-2026-16260 · CVE Program
- CVE-2026-16260 · NVD
- FIRST EPSS
- GHSA-9jf6-vw36-77hj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences