Clearfy < 2.4.3 - Admin+ PHP Object Injection via Settings Import
Priority LOW 19CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
The Clearfy Cache WordPress plugin before 2.4.3 does not restrict the classes allowed when unserializing settings-import data, allowing users with administrator access to perform PHP Object Injection attacks, which may lead to remote code execution when a suitable gadget chain is present in the environment.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00367 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Clearfy Cache (Unknown): 2.4.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Clearfy Cache | before 2.4.3 | 2.4.3 | Patch available | CNA |
- Clearfy Cache VendorUnknown Affected before 2.4.3 Fixed in 2.4.3 Patch available CNA
Remediation
- Fix · CNA Clearfy Cache (Unknown) Fixed in 2.4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-16297
- 2026-10-03 Alias added: GHSA-5953-j744-chvm
References
Sources
- CVE-2026-16297 · CVE Program
- CVE-2026-16297 · NVD
- FIRST EPSS
- GHSA-5953-j744-chvm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences