Newsletters < 4.17 - Arbitrary Plugin Option Update via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The Newsletters WordPress plugin before 4.17 does not perform any nonce or capability check when saving one of its settings screens, and writes every submitted parameter into its own options, allowing attackers to make a logged in administrator overwrite arbitrary Newsletters WordPress plugin before 4.17 settings, including the credential protecting its API, via a Cross-Site Request Forgery attack.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Newsletters | before 4.17 | 4.17 | Patch available | CNA |
- Newsletters VendorUnknown Affected before 4.17 Fixed in 4.17 Patch available CNA
Remediation
- Fix · CNA Newsletters (Unknown) Fixed in 4.17
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Newsletters 4.17
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-14372 Newsletters < 4.17 - Unauthenticated API Access via Predictable API KeyPriority LOW 21
Timeline
- 2026-10-02 Threatist record created from CVE-2026-17522
- 2026-10-03 Alias added: GHSA-mx7c-44xm-6gm6
References
Sources
- CVE-2026-17522 · CVE Program
- CVE-2026-17522 · NVD
- FIRST EPSS
- GHSA-mx7c-44xm-6gm6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences