Cross-site scripting in nice-select2
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Versions of the package nice-select2 before 2.4.1 are vulnerable to Cross-site Scripting (XSS) via the <select> element. An attacker can supply a malicious payload that is rendered directly into the DOM without proper sanitization, causing arbitrary script execution in a victim’s browser when they view or interact with the affected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | nice-select2 | before 2.4.1 | 2.4.1 | Patch available | CNA |
- nice-select2 Vendor— Affected before 2.4.1 Fixed in 2.4.1 Patch available CNA
Remediation
- Fix · CNA nice-select2 Fixed in 2.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-17528
- 2026-10-03 Alias added: GHSA-v2fq-q39g-3748
References
Sources
- CVE-2026-17528 · CVE Program
- CVE-2026-17528 · NVD
- FIRST EPSS
- GHSA-v2fq-q39g-3748 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences