WooCommerce Subscriptions < 9.1.0 - Unauthenticated RCE via PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-434.
Summary
The WooCommerce Subscriptions WordPress plugin before 9.1.0 does not validate user input before unserializing it on stores with High-Performance Order Storage enabled, leading to a PHP Object Injection issue which unauthenticated users can escalate to Remote Code Execution via a gadget chain present in the bundled dependencies.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WooCommerce Subscriptions | 4.7.0 to before 9.1.0 | 9.1.0 | Patch available | CNA |
- WooCommerce Subscriptions VendorUnknown Affected 4.7.0 to before 9.1.0 Fixed in 9.1.0 Patch available CNA
Remediation
- Fix · CNA WooCommerce Subscriptions (Unknown) Fixed in 9.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-18391
- 2026-10-03 Alias added: GHSA-5736-34m2-3cxc
References
Sources
- CVE-2026-18391 · CVE Program
- CVE-2026-18391 · NVD
- FIRST EPSS
- GHSA-5736-34m2-3cxc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences