Baserow 2FA Verify Endpoint views.py verify improper authentication
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
A vulnerability was identified in Baserow up to 2.3.2. Affected by this vulnerability is the function verify of the file backend/src/baserow/api/two_factor_auth/views.py of the component 2FA Verify Endpoint. Such manipulation leads to improper authentication. The attack may be launched remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. Upgrading to version 2.3.3 addresses this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Baserow | 2.3.0; 2.3.1; 2.3.2 | 2.3.3 | Patch available | CNA |
- Baserow Vendor— Affected 2.3.0; 2.3.1; 2.3.2 Fixed in 2.3.3 Patch available CNA
Remediation
- Fix · CNA Baserow Fixed in 2.3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-18816
- 2026-10-03 Alias added: GHSA-qq7f-jmv3-wgr8
References
Sources
- CVE-2026-18816 · CVE Program
- CVE-2026-18816 · NVD
- FIRST EPSS
- GHSA-qq7f-jmv3-wgr8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences