qpcache NOQNAME proof use-after-free crashes recursive resolver
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 8 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
An attacker may be able to cause a `named` resolver to abort. The attack requires inducing the victim resolver to send multiple queries for a DNSSEC-signed zone hosted by an authoritative server under the control of the attacker. If the auth responds with a particular sequence of crafted answers, and those answers arrive in a particular order with particular timing, the `named` resolver will encounter a use-after-free bug, and abort. This issue affects BIND 9 versions 9.11.0 through 9.18.50, 9.20.0 through 9.20.27, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.27-S1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Red Hat 6 advisories
- RHSA-2026:94011 Released 2026-11-02 · Red Hat rating Importantbind9.16 security update
- Red Hat Enterprise Linux AppStream (v. 8) bind9.16-32:9.16.23-0.22.el8_10.21, bind9.16-chroot-32:9.16.23-0.22.el8_10.21, bind9.16-dnssec-utils-32:9.16.23-0.22.el8_10.21 +4
- Red Hat Enterprise Linux CRB (v. 8) bind9.16-devel-32:9.16.23-0.22.el8_10.21, bind9.16-doc-32:9.16.23-0.22.el8_10.21, bind9.16-libs-32:9.16.23-0.22.el8_10.21
- RHSA-2026:93925 Released 2026-11-02 · Red Hat rating Importantbind security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) bind-32:9.11.36-18.el8_10, bind-chroot-32:9.11.36-18.el8_10, bind-devel-32:9.11.36-18.el8_10 +12
- Red Hat Enterprise Linux BaseOS (v. 8) bind-32:9.11.36-18.el8_10, bind-export-devel-32:9.11.36-18.el8_10, bind-export-libs-32:9.11.36-18.el8_10
- RHSA-2026:90328 Released 2026-10-26 · Red Hat rating Moderatebind security update
- Red Hat Enterprise Linux AppStream (v. 10) bind-32:9.18.33-15.el10_2.13, bind-chroot-32:9.18.33-15.el10_2.13, bind-dnssec-utils-32:9.18.33-15.el10_2.13 +3
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) bind-devel-32:9.18.33-15.el10_2.13, bind-doc-32:9.18.33-15.el10_2.13
Show 3 more Red Hat advisories
- RHSA-2026:89746 Released 2026-10-26 · Red Hat rating Moderatebind9.18 security update
- Red Hat Enterprise Linux AppStream (v. 9) bind9.18-32:9.18.29-14.el9_8.11, bind9.18-chroot-32:9.18.29-14.el9_8.11, bind9.18-dnssec-utils-32:9.18.29-14.el9_8.11 +2
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) bind9.18-devel-32:9.18.29-14.el9_8.11, bind9.18-doc-32:9.18.29-14.el9_8.11, bind9.18-libs-32:9.18.29-14.el9_8.11
- RHSA-2026:89745 Released 2026-10-26 · Red Hat rating Moderatebind security update
- Red Hat Enterprise Linux AppStream (v. 9) bind-32:9.16.23-40.el9_8.12, bind-chroot-32:9.16.23-40.el9_8.12, bind-dnssec-doc-32:9.16.23-40.el9_8.12 +5
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) bind-devel-32:9.16.23-40.el9_8.12, bind-doc-32:9.16.23-40.el9_8.12, bind-libs-32:9.16.23-40.el9_8.12
- RHSA-2026:68279 Released 2026-09-16 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images bind-32:9.20.29-0.1.hum1@aarch64, bind-32:9.20.29-0.1.hum1@src, bind-32:9.20.29-0.1.hum1@x86_64 +12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 5 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2026:90328 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2026:93925, RHSA-2026:94011 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2026:89745, RHSA-2026:89746 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2026:93925 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2026:94011 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2026:90328 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) | Fixed | RHSA-2026:89745, RHSA-2026:89746 |
| Red Hat Hardened Images | Fixed | RHSA-2026:68279 |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 9
- Red Hat OpenShift AI (RHOAI)
Timeline
- 2026-10-02 Threatist record created from CVE-2026-19662
- 2026-10-03 Alias added: GHSA-pqfm-7x4v-9w63
- 2026-10-16 Affected versions changed · Red Hat
- 2026-10-26 Fix available: RHSA-2026:89746 · Red Hat
- 2026-10-26 Fix available: Red Hat Enterprise Linux AppStream (v. 9), Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) · Red Hat
- 2026-10-26 Fix available: RHSA-2026:89745 · Red Hat
- 2026-10-26 Affected versions changed · Red Hat
- 2026-10-27 Fix available: Red Hat Enterprise Linux AppStream (v. 10), Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) · Red Hat
- 2026-10-29 Fix available: RHSA-2026:90328 · Red Hat
- 2026-10-30 Affected versions changed · Red Hat
- 2026-11-03 Fix available: RHSA-2026:93925 · Red Hat
- 2026-11-03 Fix available: Red Hat Enterprise Linux AppStream (v. 8), Red Hat Enterprise Linux BaseOS (v. 8) · Red Hat
- 2026-11-03 Fix available: RHSA-2026:94011 · Red Hat
- 2026-11-03 Fix available: Red Hat Enterprise Linux CRB (v. 8) · Red Hat
- 2026-11-06 Affected versions changed · Red Hat
References
Advisory 1
More ISC vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
Sources
- CVE-2026-19662 · CVE Program
- CVE-2026-19662 · NVD
- FIRST EPSS
- GHSA-pqfm-7x4v-9w63 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-19662 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences