Sensitive Information Disclosure in Discover Splunk Observability Cloud app for Splunk Enterprise
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
In Splunk Enterprise versions below 10.2.1 and 10.0.4, and Splunk Cloud Platform versions below 10.2.2510.5, 10.1.2507.16, and 10.0.2503.12, a low-privileged user that does not hold the "admin" or "power" Splunk roles could retrieve the Observability Cloud API access token through the Discover Splunk Observability Cloud app due to improper access control. This vulnerability does not affect Splunk Enterprise versions below 9.4.9 and 9.3.10 because the Discover Splunk Observability Cloud app does not come with Splunk Enterprise.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Splunk | Splunk Enterprise | 10.2 to before 10.2.1; 10.0 to before 10.0.4 | 10.2.1, 10.0.4 | Patch available | CNA |
| Splunk | Splunk Cloud Platform | 10.2.2510 to before 10.2.2510.5; 10.1.2507 to before 10.1.2507.16; 10.0.2503 to before 10.0.2503.12 | 10.2.2510.5, 10.1.2507.16, 10.0.2503.12 | Patch available | CNA |
- Splunk Enterprise VendorSplunk Affected 10.2 to before 10.2.1; 10.0 to before 10.0.4 Fixed in 10.2.1, 10.0.4 Patch available CNA
- Splunk Cloud Platform VendorSplunk Affected 10.2.2510 to before 10.2.2510.5; 10.1.2507 to before 10.1.2507.16; 10.0.2503 to before 10.0.2503.12 Fixed in 10.2.2510.5, 10.1.2507.16, 10.0.2503.12 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* | 10.0.0 to before 10.0.4 | Vulnerable | Splunk |
| cpe:2.3:a:splunk:splunk:10.2.0:*:*:*:enterprise:*:*:* | 10.2.0 | Vulnerable | Splunk |
| cpe:2.3:a:splunk:splunk_cloud_platform:*:*:*:*:*:*:*:* | 10.0.2503 to before 10.0.2503.12; 10.1.2507 to before 10.1.2507.16; 10.2.2510 to before 10.2.2510.5 | Vulnerable | Splunk |
- cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* Versions 10.0.0 to before 10.0.4 Vulnerable ·Splunk
- cpe:2.3:a:splunk:splunk:10.2.0:*:*:*:enterprise:*:*:* Versions 10.2.0 Vulnerable ·Splunk
- cpe:2.3:a:splunk:splunk_cloud_platform:*:*:*:*:*:*:*:* Versions 10.0.2503 to before 10.0.2503.12; 10.1.2507 to before 10.1.2507.16; 10.2.2510 to before 10.2.2510.5 Vulnerable ·Splunk
Remediation
- Fix · CNA Splunk Enterprise (Splunk) Fixed in 10.2.1, 10.0.4
- Fix · CNA Splunk Cloud Platform (Splunk) Fixed in 10.2.2510.5, 10.1.2507.16, 10.0.2503.12
Timeline
- 2026-10-02 Threatist record created from CVE-2026-20166
- 2026-10-03 Alias added: GHSA-phr8-q335-28xj
References
More Splunk vulnerabilities
- TI-2026-16444 Unauthenticated Arbitrary File Creation and Truncation in a PostgreSQL Sidecar Service Endpoint in Splunk Enterprise KEVCVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2023-24841 Remote code execution (RCE) in Splunk Enterprise through Insecure XML Parsing CVSS 3.1HIGH 8.8
- TI-2023-15979 ‘edit_user’ Capability Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2024-30707 Remote Code Execution (RCE) due to insecure session storage configuration in Splunk Enterprise on Windows CVSS 3.1HIGH 8.8
- TI-2022-21345 Reflected Cross-Site Scripting via the radio template in Splunk Enterprise CVSS 3.1HIGH 8.8
Sources
- CVE-2026-20166 · CVE Program
- CVE-2026-20166 · NVD
- FIRST EPSS
- GHSA-phr8-q335-28xj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences