Out-of-bounds write in Apple iOS and iPadOS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 18.7.5 and iPadOS 18.7.5, macOS Sonoma 14.8.4, macOS Tahoe 26.3, visionOS 26.3. Processing a maliciously crafted USD file may lead to unexpected app termination.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | iOS and iPadOS | before 18.7.5 | 18.7.5 | Patch available | CNA |
| Apple | macOS | before 14.8.4; before 26.3 | 14.8.4, 26.3 | Patch available | CNA |
| Apple | visionOS | before 26.3 | 26.3 | Patch available | CNA |
- iOS and iPadOS VendorApple Affected before 18.7.5 Fixed in 18.7.5 Patch available CNA
- macOS VendorApple Affected before 14.8.4; before 26.3 Fixed in 14.8.4, 26.3 Patch available CNA
- visionOS VendorApple Affected before 26.3 Fixed in 26.3 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:ipados:*:*:*:*:*:*:*:* | before 18.7.5 | Vulnerable | Apple |
| cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* | before 18.7.5 | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | 14.0 to before 14.8.4; 26.0 to before 26.3 | Vulnerable | Apple |
| cpe:2.3:o:apple:visionos:*:*:*:*:*:*:*:* | before 26.3 | Vulnerable | Apple |
- cpe:2.3:o:apple:ipados:*:*:*:*:*:*:*:* Versions before 18.7.5 Vulnerable ·Apple
- cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* Versions before 18.7.5 Vulnerable ·Apple
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions 14.0 to before 14.8.4; 26.0 to before 26.3 Vulnerable ·Apple
- cpe:2.3:o:apple:visionos:*:*:*:*:*:*:*:* Versions before 26.3 Vulnerable ·Apple
Remediation
- Fix · CNA iOS and iPadOS (Apple) Fixed in 18.7.5
- Fix · CNA macOS (Apple) Fixed in 14.8.4, 26.3
- Fix · CNA visionOS (Apple) Fixed in 26.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple visionOS 26.3
26 records Highest priority Priority CRITICAL 1 CRITICAL, 4 MEDIUM, 21 LOW
Other records, highest priority first
- TI-2026-16755 Memory corruption in Apple iOS and iPadOSPriority CRITICAL 93
- TI-2026-16733 Time-of-check time-of-use race condition in Apple iOS and iPadOSPriority MEDIUM 41
- TI-2026-16709 Uncontrolled resource consumption in Apple SafariPriority MEDIUM 40
- Release ·
Apple iOS and iPadOS 18.7.5
4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-16729 Apple iOS and iPadOS: Turning off "Load remote content in messages” may not apply to all…Priority LOW 30
- TI-2026-16662 Memory corruption in Apple iOS and iPadOSPriority LOW 21
- TI-2026-16713 Improper authorization in Apple SafariPriority LOW 15
Timeline
- 2026-10-02 Threatist record created from CVE-2026-20616
- 2026-10-03 Alias added: GHSA-6xrf-46c8-4wmj
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
More Apple Ipados vulnerabilities
- TI-2025-28008 Out-of-bounds write in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 10.0
- TI-2025-22441 Apple iOS and iPadOS: An attacker with arbitrary read and write capability may be able to… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-22440 Memory corruption in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 9.8
- TI-2025-17951 Out-of-bounds write in Apple Safari KEVCVSS 3.1CRITICAL 10.0
- TI-2025-17847 Use after free in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 10.0
- TI-2022-06854 Out-of-bounds write in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-20616 · CVE Program
- CVE-2026-20616 · NVD
- FIRST EPSS
- GHSA-6xrf-46c8-4wmj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences