theshit's Improper Privilege Dropping Allows Local Privilege Escalation via Command Re-execution
Priority HIGH 72CWE-250Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-250.
Summary
theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.2.0, improper privilege dropping allows local privilege escalation via command re-execution. This issue has been patched in version 0.2.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00202 10th percentileScored 2026-11-07
Fix Fixed theshit (AsfhtgkDavid): 0.2.0theshit (crates.io): 0.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AsfhtgkDavid | theshit | before 0.2.0 | 0.2.0 | Patch available | CNA |
| — | theshit (crates.io) | before 0.2.0 | 0.2.0 | Patch available | GHSA-2j3p-gqw5-g59j |
- theshit VendorAsfhtgkDavid Affected before 0.2.0 Fixed in 0.2.0 Patch available CNA
- theshit (crates.io) Vendor— Affected before 0.2.0 Fixed in 0.2.0 Patch available GHSA-2j3p-gqw5-g59j
Remediation
- Fix · CNA theshit (AsfhtgkDavid) Fixed in 0.2.0
- Fix · GHSA-2j3p-gqw5-g59j theshit (crates.io) Fixed in 0.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-21882
- 2026-10-03 Alias added: GHSA-2j3p-gqw5-g59j
References
More AsfhtgkDavid vulnerabilities
- TI-2025-42708 theshit vulnerable to unsafe loading of user-owned Python rules when running as root. CVSS 3.1MEDIUM 6.7
Sources
- CVE-2026-21882 · CVE Program
- CVE-2026-21882 · NVD
- FIRST EPSS
- GHSA-2j3p-gqw5-g59j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences