Preact has JSON VNode Injection issue
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 5 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-843 and the CVSS impact.
Summary
Preact, a lightweight web development framework, JSON serialization protection to prevent Virtual DOM elements from being constructed from arbitrary JSON. A regression introduced in Preact 10.26.5 caused this protection to be softened. In applications where values from JSON payloads are assumed to be strings and passed unmodified to Preact as children, a specially-crafted JSON payload could be constructed that would be incorrectly treated as a valid VNode. When this chain of failures occurs it can result in HTML injection, which can allow arbitrary script execution if not mitigated by CSP or other means. Applications using affected Preact versions are vulnerable if they meet all of the following conditions: first, pass unmodified, unsanitized values from user-modifiable data sources (APIs, databases, local storage, etc.) directly into the render tree; second assume these values are strings but the data source could return actual JavaScript objects instead of JSON strings; and third, the data source either fails to perform type sanitization AND blindly stores/returns raw objects interchangeably with strings, OR is compromised (e.g., poisoned local storage, filesystem, or database). Versions 10.26.10, 10.27.3, and 10.28.2 patch the issue. The patch versions restore the previous strict equality checks that prevent JSON-parsed objects from being treated as valid VNodes. Other mitigations are available for those who cannot immediately upgrade. Validate input types, cast or validate network data, sanitize external data, and use Content Security Policy (CSP).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| preactjs | preact | 10.26.5 to before 10.26.10; 10.27.0 to before 10.27.3; 10.28.0 to before 10.28.2 | 10.26.10, 10.27.3, 10.28.2 | Patch available | CNA |
| — | preact (npm) | 10.26.5 to before 10.26.10 | 10.26.10 | Patch available | GHSA-36hm-qxxp-pg3m |
| — | preact (npm) | 10.27.0 to before 10.27.3 | 10.27.3 | Patch available | GHSA-36hm-qxxp-pg3m |
| — | preact (npm) | 10.28.0 to before 10.28.2 | 10.28.2 | Patch available | GHSA-36hm-qxxp-pg3m |
- preact Vendorpreactjs Affected 10.26.5 to before 10.26.10; 10.27.0 to before 10.27.3; 10.28.0 to before 10.28.2 Fixed in 10.26.10, 10.27.3, 10.28.2 Patch available CNA
- preact (npm) Vendor— Affected 10.26.5 to before 10.26.10 Fixed in 10.26.10 Patch available GHSA-36hm-qxxp-pg3m
- preact (npm) Vendor— Affected 10.27.0 to before 10.27.3 Fixed in 10.27.3 Patch available GHSA-36hm-qxxp-pg3m
- preact (npm) Vendor— Affected 10.28.0 to before 10.28.2 Fixed in 10.28.2 Patch available GHSA-36hm-qxxp-pg3m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:preactjs:preact:*:*:*:*:*:node.js:*:* | 10.26.5 to before 10.26.10; 10.27.0 to before 10.27.3; 10.28.0 to before 10.28.2 | Vulnerable | preactjs |
- cpe:2.3:a:preactjs:preact:*:*:*:*:*:node.js:*:* Versions 10.26.5 to before 10.26.10; 10.27.0 to before 10.27.3; 10.28.0 to before 10.28.2 Vulnerable ·preactjs
Remediation
- Fix · CNA preact (preactjs) Fixed in 10.26.10, 10.27.3, 10.28.2
- Fix · GHSA-36hm-qxxp-pg3m preact (npm) Fixed in 10.26.10 Advisory →
- Fix · GHSA-36hm-qxxp-pg3m preact (npm) Fixed in 10.27.3 Advisory →
- Fix · GHSA-36hm-qxxp-pg3m preact (npm) Fixed in 10.28.2 Advisory →
Red Hat 1 advisory
- RHSA-2026:6564 Released 2026-04-09 · Red Hat rating ImportantOpenShift Container Platform 4.20.18 bug fix and security update
- Red Hat OpenShift Container Platform 4.20 registry.redhat.io/openshift4/aws-karpenter-provider-aws-rhel9, registry.redhat.io/openshift4/aws-kms-encryption-provider-rhel9, registry.redhat.io/openshift4/azure-kms-encryption-provider-rhel9 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Logging Subsystem for Red Hat OpenShift | Affected | No fix planned: Will not fix |
| OpenShift Lightspeed | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4.20 | Fixed | RHSA-2026:6564 |
Not affected: 8 products
- Logging Subsystem for Red Hat OpenShift
- Red Hat Ansible Automation Platform 2
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat OpenShift Container Platform 4.20
- streams for Apache Kafka 2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22028
- 2026-10-03 Alias added: GHSA-36hm-qxxp-pg3m
- 2026-10-09 Affected versions changed · Red Hat
References
Sources
- CVE-2026-22028 · CVE Program
- CVE-2026-22028 · NVD
- FIRST EPSS
- GHSA-36hm-qxxp-pg3m · GitHub Advisory Database · CC BY 4.0
- CVE-2026-22028 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences