Information disclosure in NetApp StorageGRID
Priority LOW 11CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
StorageGRID (formerly StorageGRID Webscale) versions prior to 11.9.0.13 and 12.0.0.6 are susceptible to a Information Disclosure vulnerability. Successful exploit could allow an authenticated attacker with low privileges to run arbitrary metrics queries, revealing metric results that they do not have access to.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00184 8th percentileScored 2026-11-07
Fix Fixed StorageGRID (formerly StorageGRID Webscale) (NETAPP): 11.9.0.13, 12.0.0.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NetApp | StorageGRID (formerly StorageGRID Webscale) | before 11.9.0.13; before 12.0.0.6 | 11.9.0.13, 12.0.0.6 | Patch available | CNA |
- StorageGRID (formerly StorageGRID Webscale) VendorNetApp Affected before 11.9.0.13; before 12.0.0.6 Fixed in 11.9.0.13, 12.0.0.6 Patch available CNA
Remediation
- Fix · CNA StorageGRID (formerly StorageGRID Webscale) (NETAPP) Fixed in 11.9.0.13, 12.0.0.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22051
- 2026-10-03 Alias added: GHSA-4fw6-xxwg-9332
References
More NetApp Storagegrid vulnerabilities
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
- TI-2025-18946 Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2025-18945 ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
- TI-2017-11487 Improper input validation in Apache HTTP Server CVSS 3.0HIGH 8.1
Sources
- CVE-2026-22051 · CVE Program
- CVE-2026-22051 · NVD
- FIRST EPSS
- GHSA-4fw6-xxwg-9332 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences