Read the docs
TI-2026-17831 Aliases CVE-2026-22221GHSA-f2x5-qvg5-jjpj

Command Injection Vulnerability on TP-Link Archer BE230 v1.2 and BE3600 v1

Priority MEDIUM 42CWE-78Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.

Summary

An OS Command Injection vulnerability in TP-Link Archer BE230 v1.2(vpn modules) and BE3600 v1 allows adjacent authenticated attacker execute arbitrary code. Successful exploitation could allow an attacker to gain full administrative control of the device, resulting in severe compromise of configuration integrity, network security, and service availability. This CVE covers one of multiple distinct OS command injection issues identified across separate code paths. Although similar in nature, each instance is tracked under a unique CVE ID. This issue affects Archer BE230 v1.2 < 1.2.4 Build 20251218 rel.70420.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01409 72nd percentileScored 2026-11-07
Fix Fixed Archer BE230 v1.2 (TP-Link Systems Inc.): 1.2.4 Build 20251218 rel.70420Archer BE3600 V1 (TP-Link Systems Inc): (KR)_V1_1.2.2 Build 20260903, (EU)_V1_1.2.6 Build 20260617, (USW)_V1.26_1.2.6 Build 20260617

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
TP-LinkArcher BE230 v1.2before 1.2.4 Build 20251218 rel.704201.2.4 Build 20251218 rel.70420Patch availableCNA
TP-LinkArcher BE3600 V1before (KR)_V1_1.2.2 Build 20260903; before (EU)_V1_1.2.6 Build 20260617; before (USW)_V1.26_1.2.6 Build 20260617(KR)_V1_1.2.2 Build 20260903, (EU)_V1_1.2.6 Build 20260617, (USW)_V1.26_1.2.6 Build 20260617Patch availableCNA
  • Archer BE230 v1.2 VendorTP-Link Affected before 1.2.4 Build 20251218 rel.70420 Fixed in 1.2.4 Build 20251218 rel.70420 Patch available CNA
  • Archer BE3600 V1 VendorTP-Link Affected before (KR)_V1_1.2.2 Build 20260903; before (EU)_V1_1.2.6 Build 20260617; before (USW)_V1.26_1.2.6 Build 20260617 Fixed in (KR)_V1_1.2.2 Build 20260903, (EU)_V1_1.2.6 Build 20260617, (USW)_V1.26_1.2.6 Build 20260617 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:o:tp-link:archer_be230_firmware:*:*:*:*:*:*:*:*before 1.2.4VulnerableTP-Link
cpe:2.3:h:tp-link:archer_be230:1.20:*:*:*:*:*:*:*1.20Running onTP-Link
  • cpe:2.3:o:tp-link:archer_be230_firmware:*:*:*:*:*:*:*:* Versions before 1.2.4 Vulnerable ·TP-Link
  • cpe:2.3:h:tp-link:archer_be230:1.20:*:*:*:*:*:*:* Versions 1.20 Running on ·TP-Link

Remediation

  • Fix · CNA Archer BE230 v1.2 (TP-Link Systems Inc.) Fixed in 1.2.4 Build 20251218 rel.70420
  • Fix · CNA Archer BE3600 V1 (TP-Link Systems Inc) Fixed in (KR)_V1_1.2.2 Build 20260903, (EU)_V1_1.2.6 Build 20260617, (USW)_V1.26_1.2.6 Build 20260617

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    TP Link Systems Archer BE230 v1.2, Archer BE3600 v1 — tp-link.com/us/support/faq/4935

    10 records Highest priority Priority MEDIUM 10 MEDIUM

    Other records, highest priority first

    • TI-2026-17837 Command Injection Vulnerability on TP-Link Archer BE230 v1.2Priority MEDIUM 44
    • TI-2026-17836 Command Injection Vulnerability on TP-Link Archer BE230 and AX73Priority MEDIUM 44
    • TI-2026-17835 Command Injection Vulnerability on TP-Link Archer BE230 v1.2 and AXE75 v1.0Priority MEDIUM 44

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-22221
  2. 2026-10-03 Alias added: GHSA-f2x5-qvg5-jjpj

References

  • TI-2026-17837 Command Injection Vulnerability on TP-Link Archer BE230 v1.2 CVSS 4.0HIGH 8.5
  • TI-2026-17836 Command Injection Vulnerability on TP-Link Archer BE230 and AX73 CVSS 4.0HIGH 8.5
  • TI-2026-17835 Command Injection Vulnerability on TP-Link Archer BE230 v1.2 and AXE75 v1.0 CVSS 4.0HIGH 8.5
  • TI-2026-17834 Command Injection Vulnerability on TP-Link Archer BE230 v1.2 CVSS 4.0HIGH 8.5
  • TI-2026-17839 Command Injection Vulnerability on TP-Link Archer BE230 v1.2 and Deco BE25 v1.0 CVSS 4.0HIGH 8.6
  • TI-2026-17833 Command Injection Vulnerability on TP-Link Archer BE230 v1.2 and BE3600 v1 CVSS 4.0HIGH 8.5
See all 11 →

Sources