CoreShop Vulnerable to SQL Injection via Admin Reports
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
CoreShop is a Pimcore enhanced eCommerce solution. Prior to version 4.1.8, a blind SQL injection vulnerability exists in the application that allows an authenticated administrator-level user to extract database contents using boolean-based or time-based techniques. The database account used by the application is read-only and non-DBA, limiting impact to confidential data disclosure only. No data modification or service disruption is possible. This issue has been patched in version 4.1.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| coreshop | CoreShop | before 4.1.8 | 4.1.8 | Patch available | CNA |
| — | coreshop/core-shop (Packagist) | before 4.1.8 | 4.1.8 | Patch available | GHSA-ch7p-mpv4-4vg4 |
- CoreShop Vendorcoreshop Affected before 4.1.8 Fixed in 4.1.8 Patch available CNA
- coreshop/core-shop (Packagist) Vendor— Affected before 4.1.8 Fixed in 4.1.8 Patch available GHSA-ch7p-mpv4-4vg4
Remediation
- Fix · CNA CoreShop (coreshop) Fixed in 4.1.8
- Fix · GHSA-ch7p-mpv4-4vg4 coreshop/core-shop (Packagist) Fixed in 4.1.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22242
- 2026-10-03 Alias added: GHSA-ch7p-mpv4-4vg4
References
More Coreshop vulnerabilities
- TI-2026-19301 CoreShop Vulnerable to SQL Injection via Admin customer-company-modifier CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-22242 · CVE Program
- CVE-2026-22242 · NVD
- FIRST EPSS
- GHSA-ch7p-mpv4-4vg4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences