UAA User Token Revocation logic error
Priority LOW 28CWE-640Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-640.
Summary
Inappropriate user token revocation due to a logic error in the token revocation endpoint implementation in Cloudfoundry UAA v77.30.0 to v78.7.0 and in Cloudfoundry Deployment v48.7.0 to v54.10.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00255 17th percentileScored 2026-11-07
Fix Fixed org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): 78.8.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CloudFoundry Foundation | UAA | 77.30.0 – v78.7.0 | — | No fix listed | CNA |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 77.30.0 to before 78.8.0 | 78.8.0 | Patch available | GHSA-6wcw-r64p-qrrw |
- UAA VendorCloudFoundry Foundation Affected 77.30.0 – v78.7.0 Fixed in — No fix listed CNA
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 77.30.0 to before 78.8.0 Fixed in 78.8.0 Patch available GHSA-6wcw-r64p-qrrw
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudfoundry:cf-deployment:*:*:*:*:*:*:*:* | after 48.7.0, up to 54.11.0 | Vulnerable | CloudFoundry Foundation |
| cpe:2.3:a:cloudfoundry:uaa-release:*:*:*:*:*:*:*:* | 77.30.0 to before 78.8.0 | Vulnerable | CloudFoundry Foundation |
- cpe:2.3:a:cloudfoundry:cf-deployment:*:*:*:*:*:*:*:* Versions after 48.7.0, up to 54.11.0 Vulnerable ·CloudFoundry Foundation
- cpe:2.3:a:cloudfoundry:uaa-release:*:*:*:*:*:*:*:* Versions 77.30.0 to before 78.8.0 Vulnerable ·CloudFoundry Foundation
Remediation
- Fix · GHSA-6wcw-r64p-qrrw org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 78.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22723
- 2026-10-03 Alias added: GHSA-6wcw-r64p-qrrw
References
Advisory 2
More CloudFoundry Foundation Cf-deployment vulnerabilities
- TI-2022-13629 Improper certificate validation in Cloud Foundry Diego and CF Deployment CVSS 3.1CRITICAL 9.1
- TI-2019-02813 Java Projects using HTTP to fetch dependencies CVSS 3.1CRITICAL 9.8
- TI-2019-08441 Password leak in smbdriver logs CVSS 3.1HIGH 8.8
- TI-2020-04463 Cloud Controller may allow developers to claim sensitive routes CVSS 3.1HIGH 8.8
- TI-2019-08446 A forged route service request using an invalid nonce can cause the gorouter to panic and crash CVSS 3.1HIGH 8.6
- TI-2018-01109 Insufficient session expiration in Dell EMC Cloud Controller CVSS 3.1HIGH 8.8
Sources
- CVE-2026-22723 · CVE Program
- CVE-2026-22723 · NVD
- FIRST EPSS
- GHSA-6wcw-r64p-qrrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences