Envoy Extension Policy lua scripts injection causes arbitrary command execution
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.5.7 and 1.6.2, EnvoyExtensionPolicy Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. This vulnerability is fixed in 1.5.7 and 1.6.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | gateway | before 1.5.7; 1.6.0-rc.0 to before 1.6.2 | 1.5.7, 1.6.2 | Patch available | CNA |
| — | github.com/envoyproxy/gateway (Go) | 1.6.0-rc.0 to before 1.6.2 | 1.6.2 | Patch available | GHSA-xrwg-mqj6-6m22 |
| — | github.com/envoyproxy/gateway (Go) | before 1.5.7 | 1.5.7 | Patch available | GHSA-xrwg-mqj6-6m22 |
- gateway Vendorenvoyproxy Affected before 1.5.7; 1.6.0-rc.0 to before 1.6.2 Fixed in 1.5.7, 1.6.2 Patch available CNA
- github.com/envoyproxy/gateway (Go) Vendor— Affected 1.6.0-rc.0 to before 1.6.2 Fixed in 1.6.2 Patch available GHSA-xrwg-mqj6-6m22
- github.com/envoyproxy/gateway (Go) Vendor— Affected before 1.5.7 Fixed in 1.5.7 Patch available GHSA-xrwg-mqj6-6m22
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:gateway:*:*:*:*:*:*:*:* | before 1.5.7; 1.6.0 to before 1.6.2 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:gateway:*:*:*:*:*:*:*:* Versions before 1.5.7; 1.6.0 to before 1.6.2 Vulnerable ·envoyproxy
Remediation
- Fix · CNA gateway (envoyproxy) Fixed in 1.5.7, 1.6.2
- Fix · GHSA-xrwg-mqj6-6m22 github.com/envoyproxy/gateway (Go) Fixed in 1.6.2 Advisory →
- Fix · GHSA-xrwg-mqj6-6m22 github.com/envoyproxy/gateway (Go) Fixed in 1.5.7 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Connectivity Link 1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22771
- 2026-10-03 Alias added: GHSA-xrwg-mqj6-6m22
- 2026-11-07 EPSS moved to the 50th–90th percentile
References
More envoyproxy Gateway vulnerabilities
- TI-2025-17797 Envoy Admin Interface Exposed through prometheus metrics endpoint CVSS 3.1HIGH 7.1
- TI-2025-18948 Envoy Gateway Log Injection Vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-22771 · CVE Program
- CVE-2026-22771 · NVD
- FIRST EPSS
- GHSA-xrwg-mqj6-6m22 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-22771 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences