OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution
Priority HIGH 73CWE-306Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-306.
Summary
OpenCode is an open source AI coding agent. Prior to 1.0.216, OpenCode automatically starts an unauthenticated HTTP server that allows any local process (or any website via permissive CORS) to execute arbitrary shell commands with the user's privileges. This vulnerability is fixed in 1.0.216.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.16538 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed opencode (anomalyco): 1.0.216opencode-ai (npm): 1.0.216
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| anomalyco | opencode | before 1.0.216 | 1.0.216 | Patch available | CNA |
| — | opencode-ai (npm) | before 1.0.216 | 1.0.216 | Patch available | GHSA-vxw4-wv6m-9hhh |
- opencode Vendoranomalyco Affected before 1.0.216 Fixed in 1.0.216 Patch available CNA
- opencode-ai (npm) Vendor— Affected before 1.0.216 Fixed in 1.0.216 Patch available GHSA-vxw4-wv6m-9hhh
Remediation
- Fix · CNA opencode (anomalyco) Fixed in 1.0.216
- Fix · GHSA-vxw4-wv6m-9hhh opencode-ai (npm) Fixed in 1.0.216 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22812
- 2026-10-03 Alias added: GHSA-vxw4-wv6m-9hhh
References
More anomalyco vulnerabilities
- TI-2026-82374 OS command injection in open via PowerShell on Windows CVSS 4.0HIGH 7.7
Sources
- CVE-2026-22812 · CVE Program
- CVE-2026-22812 · NVD
- FIRST EPSS
- GHSA-vxw4-wv6m-9hhh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences