ext4: fix iloc.bh leak in ext4_xattr_inode_update_ref
Priority LOW 24CWE-401Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: ext4: fix iloc.bh leak in ext4_xattr_inode_update_ref The error branch for ext4_xattr_inode_update_ref forget to release the refcount for iloc.bh. Find this when review code.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00144 3rd percentileScored 2026-11-07
Fix Partial Linux (Linux): 5.10.249, 5.15.199, 6.1.162 +6Red Hat: 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.10.246 to before 5.10.249; 5.15.195 to before 5.15.199; 6.1.157 to before 6.1.162; 6.6.113 to before 6.6.122; 6.12.54 to before 6.12.67; 5.4.301 to before 5.5; 6.17.4 to before 6.18 | 5.10.249, 5.15.199, 6.1.162, 6.6.122, 6.12.67, 5.5, 6.18 | Patch available | CNA |
| Linux | Linux | 6.18 and later | 5.10.249, 5.15.199, 6.1.162, 6.6.122, 6.12.67, 6.18.7, 6.19 | Patch available | CNA |
- Linux VendorLinux Affected 5.10.246 to before 5.10.249; 5.15.195 to before 5.15.199; 6.1.157 to before 6.1.162; 6.6.113 to before 6.6.122; 6.12.54 to before 6.12.67; 5.4.301 to before 5.5; 6.17.4 to before 6.18 Fixed in 5.10.249, 5.15.199, 6.1.162, 6.6.122, 6.12.67, 5.5, 6.18 Patch available CNA
- Linux VendorLinux Affected 6.18 and later Fixed in 5.10.249, 5.15.199, 6.1.162, 6.6.122, 6.12.67, 6.18.7, 6.19 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.4.301 to before 5.5; 5.10.246 to before 5.10.249; 5.15.195 to before 5.15.199; 6.1.157 to before 6.1.162; 6.6.113 to before 6.6.122; 6.12.54 to before 6.12.67; 6.17.4 to before 6.18.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* | 6.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* | 6.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* | 6.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* | 6.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* | 6.19 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.4.301 to before 5.5; 5.10.246 to before 5.10.249; 5.15.195 to before 5.15.199; 6.1.157 to before 6.1.162; 6.6.113 to before 6.6.122; 6.12.54 to before 6.12.67; 6.17.4 to before 6.18.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.249, 5.15.199, 6.1.162, 6.6.122, 6.12.67, 5.5, 6.18
- Fix · CNA Linux (Linux) Fixed in 5.10.249, 5.15.199, 6.1.162, 6.6.122, 6.12.67, 6.18.7, 6.19
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23145
- 2026-10-03 Alias added: GHSA-4vx7-fj8p-qpj9
- 2026-10-19 Weakness changed · CISA ADP
References
Patch 7
- https://git.kernel.org/stable/c/7c9f059c3d531a12d7ad96cd34a44b8af7c00d5f
- https://git.kernel.org/stable/c/6241cd1d0acc2363016ac55b8773ba1332dd59d7
- https://git.kernel.org/stable/c/3b00c16e42428a1ecd3a5eb9cc37f8ad9bd47626
- https://git.kernel.org/stable/c/0b06cde92f2f960f4ebe3c988c69f2711f2a24dc
- https://git.kernel.org/stable/c/8e8542c539927ae3898a4d02941f84e252e2dea1
- https://git.kernel.org/stable/c/06e26287f2e349a28ad363941ffd9076bfed8b2e
- https://git.kernel.org/stable/c/d250bdf531d9cd4096fedbb9f172bb2ca660c868
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-23145 · CVE Program
- CVE-2026-23145 · NVD
- FIRST EPSS
- GHSA-4vx7-fj8p-qpj9 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-23145 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences