wifi: mac80211: correctly decode TTLM with default link map
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: wifi: mac80211: correctly decode TTLM with default link map TID-To-Link Mapping (TTLM) elements do not contain any link mapping presence indicator if a default mapping is used and parsing needs to be skipped. Note that access points should not explicitly report an advertised TTLM with a default mapping as that is the implied mapping if the element is not included, this is even the case when switching back to the default mapping. However, mac80211 would incorrectly parse the frame and would also read one byte beyond the end of the element.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.7 and later | 6.18.9, 6.19 | Patch available | CNA |
- Linux VendorLinux Affected 6.7 and later Fixed in 6.18.9, 6.19 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.7 to before 6.18.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* | 6.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* | 6.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* | 6.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* | 6.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* | 6.19 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* | 6.19 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* | 6.19 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.7 to before 6.18.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* Versions 6.19 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* Versions 6.19 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.18.9, 6.19
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23152
- 2026-10-03 Alias added: GHSA-hqxw-2v34-r7g3
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-23152 · CVE Program
- CVE-2026-23152 · NVD
- FIRST EPSS
- GHSA-hqxw-2v34-r7g3 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-23152 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences