spi: tegra210-quad: Protect curr_xfer in tegra_qspi_combined_seq_xfer
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-476.
Summary
In the Linux kernel, the following vulnerability has been resolved: spi: tegra210-quad: Protect curr_xfer in tegra_qspi_combined_seq_xfer The curr_xfer field is read by the IRQ handler without holding the lock to check if a transfer is in progress. When clearing curr_xfer in the combined sequence transfer loop, protect it with the spinlock to prevent a race with the interrupt handler. Protect the curr_xfer clearing at the exit path of tegra_qspi_combined_seq_xfer() with the spinlock to prevent a race with the interrupt handler that reads this field. Without this protection, the IRQ handler could read a partially updated curr_xfer value, leading to NULL pointer dereference or use-after-free.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.17.13 to before 6.18 | 6.18 | Patch available | CNA |
| Linux | Linux | 5.15.198 to before 5.15.200; 6.1.160 to before 6.1.163; 6.6.120 to before 6.6.124; 6.12.63 to before 6.12.70; 6.18.2 to before 6.18.10 | 5.15.200, 6.1.163, 6.6.124, 6.12.70, 6.18.10 | Patch available | CNA |
- Linux VendorLinux Affected 6.17.13 to before 6.18 Fixed in 6.18 Patch available CNA
- Linux VendorLinux Affected 5.15.198 to before 5.15.200; 6.1.160 to before 6.1.163; 6.6.120 to before 6.6.124; 6.12.63 to before 6.12.70; 6.18.2 to before 6.18.10 Fixed in 5.15.200, 6.1.163, 6.6.124, 6.12.70, 6.18.10 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.15.198 to before 5.15.200; 6.1.160 to before 6.1.163; 6.6.120 to before 6.6.124; 6.12.63 to before 6.12.70; 6.17.13 to before 6.18; 6.18.2 to before 6.18.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* | 6.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* | 6.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* | 6.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* | 6.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* | 6.19 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* | 6.19 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* | 6.19 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* | 6.19 rc8 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.15.198 to before 5.15.200; 6.1.160 to before 6.1.163; 6.6.120 to before 6.6.124; 6.12.63 to before 6.12.70; 6.17.13 to before 6.18; 6.18.2 to before 6.18.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* Versions 6.19 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* Versions 6.19 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:rc8:*:*:*:*:*:* Versions 6.19 rc8 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.18
- Fix · CNA Linux (Linux) Fixed in 5.15.200, 6.1.163, 6.6.124, 6.12.70, 6.18.10
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23202
- 2026-10-03 Alias added: GHSA-g2fg-h3fh-wpj6
- 2026-10-19 Weakness changed · CISA ADP
References
Patch 6
- https://git.kernel.org/stable/c/9fa4262a80f751d14a6a39d2c03f57db68da2618
- https://git.kernel.org/stable/c/762e2ce71c8f0238e9eaf05d14da803d9a24422f
- https://git.kernel.org/stable/c/712cde8d916889e282727cdf304a43683adf899e
- https://git.kernel.org/stable/c/6fd446178a610a48e80e5c5b487b0707cd01daac
- https://git.kernel.org/stable/c/3bc293d5b56502068481478842f57b3d96e432c7
- https://git.kernel.org/stable/c/bf4528ab28e2bf112c3a2cdef44fd13f007781cd
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-23202 · CVE Program
- CVE-2026-23202 · NVD
- FIRST EPSS
- GHSA-g2fg-h3fh-wpj6 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-23202 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences