Read the docs
TI-2026-18675 Aliases CVE-2026-23238GHSA-wj4m-w3qm-xpch

romfs: check sb_set_blocksize() return value

Priority LOW 24CWE-617Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-617.

Summary

In the Linux kernel, the following vulnerability has been resolved: romfs: check sb_set_blocksize() return value romfs_fill_super() ignores the return value of sb_set_blocksize(), which can fail if the requested block size is incompatible with the block device's configuration. This can be triggered by setting a loop device's block size larger than PAGE_SIZE using ioctl(LOOP_SET_BLOCK_SIZE, 32768), then mounting a romfs filesystem on that device. When sb_set_blocksize(sb, ROMBSIZE) is called with ROMBSIZE=4096 but the device has logical_block_size=32768, bdev_validate_blocksize() fails because the requested size is smaller than the device's logical block size. sb_set_blocksize() returns 0 (failure), but romfs ignores this and continues mounting. The superblock's block size remains at the device's logical block size (32768). Later, when sb_bread() attempts I/O with this oversized block size, it triggers a kernel BUG in folio_set_bh(): kernel BUG at fs/buffer.c:1582! BUG_ON(size > PAGE_SIZE); Fix by checking the return value of sb_set_blocksize() and failing the mount with -EINVAL if it returns 0.

Why it matters now

EPSS 0.00215 11th percentileScored 2026-11-07
Fix Partial Linux (Linux): 5.10.251, 5.15.201, 6.1.164 +4Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux2.6.12 and later5.10.251, 5.15.201, 6.1.164, 6.6.127, 6.12.74, 6.18.13, 6.19Patch availableCNA
  • Linux VendorLinux Affected 2.6.12 and later Fixed in 5.10.251, 5.15.201, 6.1.164, 6.6.127, 6.12.74, 6.18.13, 6.19 Patch available CNA

CPE configurations NVD · 13

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*2.6.12.1 to before 5.10.251; 5.11 to before 5.15.201; 5.16 to before 6.1.164; 6.2 to before 6.6.127; 6.7 to before 6.12.74; 6.13 to before 6.18.13VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:*2.6.12VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:*2.6.12 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:*2.6.12 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:*2.6.12 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:*2.6.12 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:*6.19 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:*6.19 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:*6.19 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:*6.19 rc4VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.12.1 to before 5.10.251; 5.11 to before 5.15.201; 5.16 to before 6.1.164; 6.2 to before 6.6.127; 6.7 to before 6.12.74; 6.13 to before 6.18.13 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:* Versions 2.6.12 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:* Versions 2.6.12 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:* Versions 2.6.12 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:* Versions 2.6.12 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:* Versions 2.6.12 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc1:*:*:*:*:*:* Versions 6.19 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc2:*:*:*:*:*:* Versions 6.19 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc3:*:*:*:*:*:* Versions 6.19 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc4:*:*:*:*:*:* Versions 6.19 rc4 Vulnerable ·Linux
Show 3 more CPE
CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:*6.19 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:*6.19 rc6VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:*6.19 rc7VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc5:*:*:*:*:*:* Versions 6.19 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc6:*:*:*:*:*:* Versions 6.19 rc6 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.19:rc7:*:*:*:*:*:* Versions 6.19 rc7 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.10.251, 5.15.201, 6.1.164, 6.6.127, 6.12.74, 6.18.13, 6.19

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Not affected: 4 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-23238
  2. 2026-10-03 Alias added: GHSA-wj4m-w3qm-xpch

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources