Read the docs
TI-2026-18755 Aliases CVE-2026-23318GHSA-x63j-v2j2-m8fv

ALSA: usb-audio: Use correct version for UAC3 header validation

Priority LOW 30CWE-125Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · High
Fix status
Partial Red Hat: 4 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Use correct version for UAC3 header validation The entry of the validators table for UAC3 AC header descriptor is defined with the wrong protocol version UAC_VERSION_2, while it should have been UAC_VERSION_3. This results in the validator never matching for actual UAC3 devices (protocol == UAC_VERSION_3), causing their header descriptors to bypass validation entirely. A malicious USB device presenting a truncated UAC3 header could exploit this to cause out-of-bounds reads when the driver later accesses unvalidated descriptor fields. The bug was introduced in the same commit as the recently fixed UAC3 feature unit sub-type typo, and appears to be from the same copy-paste error when the UAC3 section was created from the UAC2 section.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00139 3rd percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.20, 5.4, 5.10.253 +7Red Hat: 4 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux4.19.84 to before 4.20; 5.3.11 to before 5.44.20, 5.4Patch availableCNA
LinuxLinux5.4 and later5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17, 6.19.7, 7.0Patch availableCNA
  • Linux VendorLinux Affected 4.19.84 to before 4.20; 5.3.11 to before 5.4 Fixed in 4.20, 5.4 Patch available CNA
  • Linux VendorLinux Affected 5.4 and later Fixed in 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17, 6.19.7, 7.0 Patch available CNA

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*4.19.84 to before 4.20; 5.3.11 to before 5.4; 5.4.1 to before 5.10.253; 5.11 to before 5.15.203; 5.16 to before 6.1.167; 6.2 to before 6.6.130; 6.7 to before 6.12.77; 6.13 to before 6.18.17; 6.19 to before 6.19.7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:5.4:-:*:*:*:*:*:*5.4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:*7.0 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:*7.0 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:*7.0 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:*7.0 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:*7.0 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:*7.0 rc6VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:*7.0 rc7VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.19.84 to before 4.20; 5.3.11 to before 5.4; 5.4.1 to before 5.10.253; 5.11 to before 5.15.203; 5.16 to before 6.1.167; 6.2 to before 6.6.130; 6.7 to before 6.12.77; 6.13 to before 6.18.17; 6.19 to before 6.19.7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:5.4:-:*:*:*:*:*:* Versions 5.4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* Versions 7.0 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* Versions 7.0 rc6 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* Versions 7.0 rc7 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 4.20, 5.4
  • Fix · CNA Linux (Linux) Fixed in 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17, 6.19.7, 7.0

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 7AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 8AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 9AffectedNo fix yet: Fix deferred
Not affected: 1 product
  • Red Hat Enterprise Linux 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-23318
  2. 2026-10-03 Alias added: GHSA-x63j-v2j2-m8fv
  3. 2026-11-05 CISA SSVC decision points changed

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources