dpaa2-switch: Fix interrupt storm after receiving bad if_id in IRQ handler
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: dpaa2-switch: Fix interrupt storm after receiving bad if_id in IRQ handler Commit 31a7a0bbeb00 ("dpaa2-switch: add bounds check for if_id in IRQ handler") introduces a range check for if_id to avoid an out-of-bounds access. If an out-of-bounds if_id is detected, the interrupt status is not cleared. This may result in an interrupt storm. Clear the interrupt status after detecting an out-of-bounds if_id to avoid the problem. Found by an experimental AI code review agent at Google.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.15.200 to before 5.15.203; 6.1.163 to before 6.1.167; 6.6.124 to before 6.6.130; 6.12.70 to before 6.12.77; 6.18.10 to before 6.18.17 | 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17 | Patch available | CNA |
| Linux | Linux | 6.19 and later | 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17, 6.19.7, 7.0 | Patch available | CNA |
- Linux VendorLinux Affected 5.15.200 to before 5.15.203; 6.1.163 to before 6.1.167; 6.6.124 to before 6.6.130; 6.12.70 to before 6.12.77; 6.18.10 to before 6.18.17 Fixed in 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17 Patch available CNA
- Linux VendorLinux Affected 6.19 and later Fixed in 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17, 6.19.7, 7.0 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.15.200 to before 5.15.203; 6.1.163 to before 6.1.167; 6.6.124 to before 6.6.130; 6.12.70 to before 6.12.77; 6.18.10 to before 6.18.17; 6.19.1 to before 6.19.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:-:*:*:*:*:*:* | 6.19 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* | 7.0 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* | 7.0 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* | 7.0 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* | 7.0 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* | 7.0 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.15.200 to before 5.15.203; 6.1.163 to before 6.1.167; 6.6.124 to before 6.6.130; 6.12.70 to before 6.12.77; 6.18.10 to before 6.18.17; 6.19.1 to before 6.19.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:-:*:*:*:*:*:* Versions 6.19 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* Versions 7.0 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* Versions 7.0 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* Versions 7.0 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17
- Fix · CNA Linux (Linux) Fixed in 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17, 6.19.7, 7.0
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23422
- 2026-10-03 Alias added: GHSA-6rph-vpvq-7wvw
References
Patch 7
- https://git.kernel.org/stable/c/7def51cb9fb8b8d5342443372b8cf28d8fbd7f3d
- https://git.kernel.org/stable/c/b5bababe7703a7322bc59b803ab1587887a2a5e4
- https://git.kernel.org/stable/c/c7becfe3e604d138bd53b8ac3111b2b3e8ec6b0e
- https://git.kernel.org/stable/c/fa4412cdc5178a48799bafcb8af28fd2fbf3d703
- https://git.kernel.org/stable/c/00f42ace446f1e4bf84988f2281131f52cd32796
- https://git.kernel.org/stable/c/28fd8ac1d49389cb230d712116f54e27ebec11b8
- https://git.kernel.org/stable/c/74badb9c20b1a9c02a95c735c6d3cd6121679c93
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-23422 · CVE Program
- CVE-2026-23422 · NVD
- FIRST EPSS
- GHSA-6rph-vpvq-7wvw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-23422 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences