net/mlx5e: Fix race condition during IPSec ESN update
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: net/mlx5e: Fix race condition during IPSec ESN update In IPSec full offload mode, the device reports an ESN (Extended Sequence Number) wrap event to the driver. The driver validates this event by querying the IPSec ASO and checking that the esn_event_arm field is 0x0, which indicates an event has occurred. After handling the event, the driver must re-arm the context by setting esn_event_arm back to 0x1. A race condition exists in this handling path. After validating the event, the driver calls mlx5_accel_esp_modify_xfrm() to update the kernel's xfrm state. This function temporarily releases and re-acquires the xfrm state lock. So, need to acknowledge the event first by setting esn_event_arm to 0x1. This prevents the driver from reprocessing the same ESN update if the hardware sends events for other reason. Since the next ESN update only occurs after nearly 2^31 packets are received, there's no risk of missing an update, as it will happen long after this handling has finished. Processing the event twice causes the ESN high-order bits (esn_msb) to be incremented incorrectly. The driver then programs the hardware with this invalid ESN state, which leads to anti-replay failures and a complete halt of IPSec traffic. Fix this by re-arming the ESN event immediately after it is validated, before calling mlx5_accel_esp_modify_xfrm(). This ensures that any spurious, duplicate events are correctly ignored, closing the race window.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.4 and later | 6.6.130, 6.12.78, 6.18.20, 6.19.10, 7.0 | Patch available | CNA |
- Linux VendorLinux Affected 6.4 and later Fixed in 6.6.130, 6.12.78, 6.18.20, 6.19.10, 7.0 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.4.1 to before 6.6.130; 6.7 to before 6.12.78; 6.13 to before 6.18.20; 6.19 to before 6.19.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:-:*:*:*:*:*:* | 6.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* | 7.0 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* | 7.0 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* | 7.0 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* | 7.0 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* | 7.0 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.4.1 to before 6.6.130; 6.7 to before 6.12.78; 6.13 to before 6.18.20; 6.19 to before 6.19.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:-:*:*:*:*:*:* Versions 6.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* Versions 7.0 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* Versions 7.0 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* Versions 7.0 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.6.130, 6.12.78, 6.18.20, 6.19.10, 7.0
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 3 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23440
- 2026-10-03 Alias added: GHSA-255w-8g7g-qmg6
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-19 Weakness changed · CISA ADP
- 2026-10-29 Affected versions changed · Red Hat
References
Patch 5
- https://git.kernel.org/stable/c/3dffc083292e6872787bd7e34b957627622f9af4
- https://git.kernel.org/stable/c/2051c709dce92da3550040aa7949cd5a9c89b14e
- https://git.kernel.org/stable/c/96c9c25b74686ac2de15921c9ad30c5ef13af8cd
- https://git.kernel.org/stable/c/8d625c15471fb8780125eaef682983a96af77bdc
- https://git.kernel.org/stable/c/beb6e2e5976a128b0cccf10d158124422210c5ef
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-23440 · CVE Program
- CVE-2026-23440 · NVD
- FIRST EPSS
- GHSA-255w-8g7g-qmg6 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-23440 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences