net: usb: cdc_ncm: add ndpoffset to NDP32 nframes bounds check
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-129 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: net: usb: cdc_ncm: add ndpoffset to NDP32 nframes bounds check The same bounds-check bug fixed for NDP16 in the previous patch also exists in cdc_ncm_rx_verify_ndp32(). The DPE array size is validated against the total skb length without accounting for ndpoffset, allowing out-of-bounds reads when the NDP32 is placed near the end of the NTB. Add ndpoffset to the nframes bounds check and use struct_size_t() to express the NDP-plus-DPE-array size more clearly. Compile-tested only.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.14.317 to before 4.15; 4.19.285 to before 4.20; 5.4.245 to before 5.5 | 4.15, 4.20, 5.5 | Patch available | CNA |
| Linux | Linux | 5.7 and later | 6.1.188, 6.6.130, 6.12.78, 6.18.20, 6.19.10, 7.0 | Patch available | CNA |
- Linux VendorLinux Affected 4.14.317 to before 4.15; 4.19.285 to before 4.20; 5.4.245 to before 5.5 Fixed in 4.15, 4.20, 5.5 Patch available CNA
- Linux VendorLinux Affected 5.7 and later Fixed in 6.1.188, 6.6.130, 6.12.78, 6.18.20, 6.19.10, 7.0 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.14.317 to before 4.15; 4.19.285 to before 4.20; 5.4.245 to before 5.5; 5.7.1 to before 6.6.130; 6.7 to before 6.12.78; 6.13 to before 6.18.20; 6.19 to before 6.19.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.7:-:*:*:*:*:*:* | 5.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* | 7.0 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* | 7.0 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* | 7.0 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* | 7.0 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* | 7.0 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14.317 to before 4.15; 4.19.285 to before 4.20; 5.4.245 to before 5.5; 5.7.1 to before 6.6.130; 6.7 to before 6.12.78; 6.13 to before 6.18.20; 6.19 to before 6.19.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.7:-:*:*:*:*:*:* Versions 5.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* Versions 7.0 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* Versions 7.0 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* Versions 7.0 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.15, 4.20, 5.5
- Fix · CNA Linux (Linux) Fixed in 6.1.188, 6.6.130, 6.12.78, 6.18.20, 6.19.10, 7.0
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23447
- 2026-10-03 Alias added: GHSA-vf6v-fqr8-5xhj
- 2026-11-05 CISA SSVC decision points changed
References
Patch 5
- https://git.kernel.org/stable/c/125f932a76a97904ef8a555f1dd53e5d0e288c54
- https://git.kernel.org/stable/c/af0d1613d6751489dbf9f69aac1123f0b1e566e5
- https://git.kernel.org/stable/c/a5bd5a2710310c965ea4153cba4210988a3454e2
- https://git.kernel.org/stable/c/de70da1fb1d152e981ecb3157f7ec2b633005c16
- https://git.kernel.org/stable/c/77914255155e68a20aa41175edeecf8121dac391
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-23447 · CVE Program
- CVE-2026-23447 · NVD
- FIRST EPSS
- GHSA-vf6v-fqr8-5xhj · GitHub Advisory Database · CC BY 4.0
- CVE-2026-23447 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences