Read the docs
TI-2026-19029 Aliases CVE-2026-23630

Docmost is vulnerable to stored Cross-Site Scripting (XSS) through Mermaid rendering

Priority LOW 28CWE-116Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Docmost is open-source collaborative wiki and documentation software. In versions 0.3.0 through 0.23.2, Mermaid code block rendering is vulnerable to stored Cross-Site Scripting (XSS). The frontend can render attacker-controlled Mermaid diagrams using mermaid.render(), then inject the returned SVG/HTML into the DOM via dangerouslySetInnerHTML without sanitization. Mermaid per-diagram %%{init}%% directives allow overriding securityLevel and enabling htmlLabels, permitting arbitrary HTML/JS execution for any viewer. This issue has been fixed in version 0.24.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00292 21st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed docmost (docmost): 0.24.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
docmostdocmost0.3.0 to before 0.24.00.24.0Patch availableCNA
  • docmost Vendordocmost Affected 0.3.0 to before 0.24.0 Fixed in 0.24.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:docmost:docmost:*:*:*:*:*:*:*:*0.3.0 to before 0.24.0Vulnerabledocmost
  • cpe:2.3:a:docmost:docmost:*:*:*:*:*:*:*:* Versions 0.3.0 to before 0.24.0 Vulnerable ·docmost

Remediation

  • Fix · CNA docmost (docmost) Fixed in 0.24.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-23630

References

  • TI-2026-17859 Docmost affected by an Arbitrary File Write via Zip Import Feature (ZipSlip) CVSS 3.1CRITICAL 9.8
  • TI-2026-19373 Docmost Affected by Stored XSS in Public Share Page CVSS 3.1HIGH 7.3
  • TI-2025-35043 Cross Site Scripting vulnerability in docmost v.0.21.0 and before allows an attacker to execute arbitrary code CVSS 3.1MEDIUM 6.1
  • TI-2026-26508 Docmost has cross-page attachment overwrite via flawed attachmentId overwrite validation CVSS 3.1MEDIUM 5.4
  • TI-2026-26507 Docmost page content has stored XSS via unsanitized attachment URLs CVSS 3.1MEDIUM 5.4
  • TI-2026-29581 Docmost: XSS in Comments with JavaScript URI CVSS 3.1MEDIUM 5.4
See all 8 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences