Lobe Chat has Cross-Site Scripting (XSS) issue that may escalate to Remote Code Execution (RCE)
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
LobeChat is an open source chat application platform. Prior to version 2.0.0-next.180, a stored Cross-Site Scripting (XSS) vulnerability in the Mermaid artifact renderer allows attackers to execute arbitrary JavaScript within the application context. This XSS can be escalated to Remote Code Execution (RCE) by leveraging the exposed `electronAPI` IPC bridge, allowing attackers to run arbitrary system commands on the victim's machine. Version 2.0.0-next.180 patches the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| lobehub | lobe-chat | before 2.0.0-next.180 | 2.0.0-next.180 | Patch available | CNA |
| — | @lobehub/chat (npm) | up to 1.143.2 | — | No fix listed | GHSA-4gpc-rhpj-9443 |
- lobe-chat Vendorlobehub Affected before 2.0.0-next.180 Fixed in 2.0.0-next.180 Patch available CNA
- @lobehub/chat (npm) Vendor— Affected up to 1.143.2 Fixed in — No fix listed GHSA-4gpc-rhpj-9443
Remediation
- Fix · CNA lobe-chat (lobehub) Fixed in 2.0.0-next.180
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23733
- 2026-10-03 Alias added: GHSA-4gpc-rhpj-9443
References
More lobehub vulnerabilities
- TI-2026-39067 LobeHub: Unauthenticated SSRF in `/webapi/proxy` CVSS 3.1CRITICAL 9.0
- TI-2026-83681 Path traversal in LobeHub Chat lets users write arbitrary files CVSS 4.0HIGH 8.7
- TI-2024-31448 Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964) CVSS 3.1CRITICAL 9.0
- TI-2024-21831 lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.0
- TI-2026-58746 LobeChat 2.2.1 Webhook Signature Verification Bypass QQ Feishu CVSS 4.0MEDIUM 6.9
- TI-2024-21832 ssrf vulnerability in lobe-chat CVSS 3.1HIGH 8.6
Sources
- CVE-2026-23733 · CVE Program
- CVE-2026-23733 · NVD
- FIRST EPSS
- GHSA-4gpc-rhpj-9443 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences